qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH v2] spapr-pci: fix config space access to suppor


From: Alexander Graf
Subject: Re: [Qemu-devel] [PATCH v2] spapr-pci: fix config space access to support bridges
Date: Fri, 16 Aug 2013 15:04:16 +0200

On 16.08.2013, at 13:09, Alexey Kardashevskiy wrote:

> spapr-pci config space accessors use find_dev() to find a PCI device.
> However find_dev() only searched on a primary bus and did not do
> recursive search through secondary buses so config space access was not
> possible for devices other that on a primary bus.
> 
> This fixed find_dev() by using the PCI API pci_find_device() function.
> This effectively enabled pci bridges on spapr.
> 
> Signed-off-by: Alexey Kardashevskiy <address@hidden>
> ---
> 
> Does not it make sense to move spapr_pci.c from hw/ppc to hw/pci? We already
> do move interrupt controllers to hw/intc.
> 
> 
> ---
> Changes:
> v2:
> * fixed coding style
> * config space access traces moved out
> ---
> hw/ppc/spapr_pci.c | 11 +----------
> 1 file changed, 1 insertion(+), 10 deletions(-)
> 
> diff --git a/hw/ppc/spapr_pci.c b/hw/ppc/spapr_pci.c
> index 1ca35a0..91d78a6 100644
> --- a/hw/ppc/spapr_pci.c
> +++ b/hw/ppc/spapr_pci.c
> @@ -65,22 +65,13 @@ static PCIDevice *find_dev(sPAPREnvironment *spapr, 
> uint64_t buid,
> {
>     sPAPRPHBState *sphb = find_phb(spapr, buid);
>     PCIHostState *phb = PCI_HOST_BRIDGE(sphb);
> -    BusState *bus = BUS(phb->bus);
> -    BusChild *kid;
>     int devfn = (config_addr >> 8) & 0xFF;
> 
>     if (!phb) {
>         return NULL;
>     }
> 
> -    QTAILQ_FOREACH(kid, &bus->children, sibling) {
> -        PCIDevice *dev = (PCIDevice *)kid->child;
> -        if (dev->devfn == devfn) {
> -            return dev;
> -        }
> -    }
> -
> -    return NULL;
> +    return pci_find_device(phb->bus, (config_addr >> 16) & 0xff, devfn);

Please put the (config_addr >> 16) into a separate variable so it's obvious 
what we're passing in here. Otherwise looks like a reasonably straight forward 
change to me, but I'd like to see an ack from Michael.


Alex




reply via email to

[Prev in Thread] Current Thread [Next in Thread]