qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH 1/3] qxl: add fb_size_mb and fb_size


From: Gerd Hoffmann
Subject: Re: [Qemu-devel] [PATCH 1/3] qxl: add fb_size_mb and fb_size
Date: Mon, 11 Jun 2012 09:42:28 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:10.0.5) Gecko/20120601 Thunderbird/10.0.5

  Hi,

> +        if (d->fb_size < fb) {
> +            d->fb_size = fb;
> +        }
> +        if (fb <= d->fb_size) {

This check doesn't make sense, it will always be true.

> +    if (qxl->fb_size_mb != -1 &&
> +        qxl->fb_size_mb * 1024 * 1024 < qxl->vga.vram_size) {
> +        qxl->fb_size = qxl->fb_size_mb * 1024 * 1024;
> +    } else {
> +        qxl->fb_size = VGA_RAM_SIZE;
> +    }

Reminds me that I have some pending work to make vga ram size
configurable which I should finish and repost ...

Current state pushed to http://www.kraxel.org/cgit/qemu/log/?h=vga.1

It probably makes sense to base this on top.

> +        DEFINE_PROP_UINT32("fb_size_mb", PCIQXLDevice, fb_size_mb, -1),

Maybe also rename this to vgamem_mb for consistency with standard vga.

cheers,
  Gerd



reply via email to

[Prev in Thread] Current Thread [Next in Thread]