qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCHv4 05/11] qxl: add io_port_to_string


From: Gerd Hoffmann
Subject: Re: [Qemu-devel] [PATCHv4 05/11] qxl: add io_port_to_string
Date: Thu, 14 Jul 2011 10:37:02 +0200
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.18) Gecko/20110617 Red Hat/3.1.11-2.el6_1 Thunderbird/3.1.11

On 07/13/11 16:49, Alon Levy wrote:
Signed-off-by: Alon Levy<address@hidden>
---
  hw/qxl.c |   61 ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++-
  1 files changed, 60 insertions(+), 1 deletions(-)

diff --git a/hw/qxl.c b/hw/qxl.c
index e41f8cc..2ecc932 100644
--- a/hw/qxl.c
+++ b/hw/qxl.c
@@ -408,6 +408,64 @@ static const char *qxl_mode_to_string(int mode)
      return "INVALID";
  }

+static const char *io_port_to_string(uint32_t io_port)
+{
+    if (io_port>= QXL_IO_RANGE_SIZE) {
+        return "out of range";
+    }
+    switch (io_port) {
+    case QXL_IO_NOTIFY_CMD:
+        return "QXL_IO_NOTIFY_CMD";
+    case QXL_IO_NOTIFY_CURSOR:
+        return "QXL_IO_NOTIFY_CURSOR";

That becomes alot more readable when using a c99 array for it:

static const char *io_port_names[QXL_IO_RANGE_SIZE] = {
    [ QXL_IO_NOTIFY_CMD ]    = "notify-cmd",
    [ QXL_IO_NOTIFY_CURSOR ] = "notify-cursor",
    [ ... ]
};




reply via email to

[Prev in Thread] Current Thread [Next in Thread]