qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH v2 4/6] atapi: GESN: Use structs for commonly-us


From: Kevin Wolf
Subject: Re: [Qemu-devel] [PATCH v2 4/6] atapi: GESN: Use structs for commonly-used field types
Date: Tue, 12 Apr 2011 12:07:15 +0200
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.15) Gecko/20101027 Fedora/3.0.10-1.fc12 Thunderbird/3.0.10

Am 12.04.2011 11:27, schrieb Amit Shah:
> Instead of using magic numbers, use structs that are more descriptive of
> the fields being used.
> 
> Signed-off-by: Amit Shah <address@hidden>
> ---
>  hw/ide/core.c |   15 +++++++++++++--
>  1 files changed, 13 insertions(+), 2 deletions(-)
> 
> diff --git a/hw/ide/core.c b/hw/ide/core.c
> index c5913d8..fe50d8a 100644
> --- a/hw/ide/core.c
> +++ b/hw/ide/core.c
> @@ -1097,12 +1097,23 @@ static void 
> handle_get_event_status_notification(IDEState *s,
>                                                   uint8_t *buf,
>                                                   const uint8_t *packet)
>  {
> +    struct {
> +        uint8_t opcode;
> +        uint8_t polled;   /* lsb bit is polled; others are reserved */
> +        uint8_t reserved2[2];
> +        uint8_t request;

Maybe class would be a better name?

> +        uint8_t reserved3[2];
> +        uint8_t len_msb;
> +        uint8_t len_lsb;

Why not a uint16_t length?

> +        uint8_t control;
> +    } __attribute__((packed)) *gesn_cdb;
>      unsigned int max_len, used_len;
>  
> -    max_len = ube16_to_cpu(packet + 7);
> +    gesn_cdb = (void *)packet;
> +    max_len = ube16_to_cpu(&gesn_cdb->len_msb);

Instead of reading 16 bit from a 8 bit pointer, you could then use
be16_to_cpu(gesn_cdb->length);

>  
>      /* It is fine by the MMC spec to not support async mode operations */
> -    if (!(packet[1] & 0x01)) { /* asynchronous mode */
> +    if (!(gesn_cdb->polled & 0x01)) { /* asynchronous mode */
>          /* Only polling is supported, asynchronous mode is not. */
>          ide_atapi_cmd_error(s, SENSE_ILLEGAL_REQUEST,
>                              ASC_INV_FIELD_IN_CMD_PACKET);

Kevin



reply via email to

[Prev in Thread] Current Thread [Next in Thread]