[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] Networking under Hurd quest still not working

From: Nigel Horne
Subject: Re: [Qemu-devel] Networking under Hurd quest still not working
Date: Sat, 10 Jul 2010 09:16:36 +0100
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20100620 Icedove/3.0.5

On 10/07/10 09:02, Aurelien Jarno wrote:
On Sat, Jul 10, 2010 at 08:42:04AM +0100, Nigel Horne wrote:

Thank you for your reply.
I've rebuild QEMU and gone back to old images of the Hurd when
networking was working (to eliminate that as a cause).  Networking is
still not working with the latest Git version of QEMU with Linux host
and Hurd guest.

Do you have more details about that? I haven't been able to reproduce
the problem here. Would be nice to have an image and the command line
you used.

I originally got the image from
http://www.gnu.org/software/hurd/hurd/running/qemu.html (click on
"Readily Available Images").  I've made a few changes since then
(primarily a few apt-get updates and upgrades).

The command line is "qemu -hda debian-hurd-k16-qemu.img -m 512 -boot c
-net nic,model=rtl8139 -net user --enable-kvm"
Here the network already works correctly at this point.

The commands I used to get the networking running were:
settrans -afgp /servers/socket/2 /hurd/pfinet -i eth0 -a -g -m
echo "nameserver">  /etc/resolv.conf
Even after those lines it still continues to work.
So what next?

Nigel Horne. Arranger, Adjudicator, Band Trainer, Composer, Tutor, Typesetter.
NJH Music, ICQ#20252325, twitter: @nigelhorne
address@hidden http://www.bandsman.co.uk

reply via email to

[Prev in Thread] Current Thread [Next in Thread]