qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] Re: [PATCH 1/6] PCI config space access overhaul


From: Alexander Graf
Subject: Re: [Qemu-devel] Re: [PATCH 1/6] PCI config space access overhaul
Date: Tue, 12 Jan 2010 11:38:33 +0100

On 05.01.2010, at 23:16, Michael S. Tsirkin wrote:

> On Mon, Jan 04, 2010 at 08:32:50AM +0100, Alexander Graf wrote:
>> +typedef void (*pci_config_reg_fn)(PCIHostState *s, uint32_t config_reg,
>> +                                  PCIConfigAddress *conf);
>> +
> 
> pci_decode_config_addr_fn would be a better name.
> 
>> struct PCIHostState {
>>     SysBusDevice busdev;
>> +    pci_config_reg_fn decode_config_reg;
>> +    PCIConfigAddress config_reg_dec;
> 
> decode_config_addr
> and
> config_addr
> 
> would be better names
> 
>>     uint32_t config_reg;
>>     PCIBus *bus;
>> };
>> 
>> void pci_data_write(PCIBus *s, uint32_t addr, uint32_t val, int len);
>> uint32_t pci_data_read(PCIBus *s, uint32_t addr, int len);
>> +void pci_host_init(PCIHostState *s);
>> +void pci_host_decode_config_reg(PCIHostState *s, uint32_t config_reg,
>> +                                PCIConfigAddress *decoded);
> 
> Shouldn't this be static?

No, since I want to call it from unin for the OpenBIOS compatibility call. We 
still use the x86 encoding for the BIOS (for now).

> And again, pci_host_decode_config_addr would be a better name IMO.

Alrighty.

Alex



reply via email to

[Prev in Thread] Current Thread [Next in Thread]