qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH] replace duplicated code.


From: Mark McLoughlin
Subject: Re: [Qemu-devel] [PATCH] replace duplicated code.
Date: Thu, 18 Jun 2009 08:39:53 +0100

On Wed, 2009-06-17 at 18:52 -0400, Glauber Costa wrote:
> pci_register_simple() does exactly the same of great part of the code
> in pci nic initialization. Replace it.
> 
> Signed-off-by: Glauber Costa <address@hidden>
> ---
>  hw/pci.c  |   12 ++++--------
>  hw/qdev.c |    1 +
>  2 files changed, 5 insertions(+), 8 deletions(-)
> 
> diff --git a/hw/pci.c b/hw/pci.c
> index baffadd..0169b78 100644
> --- a/hw/pci.c
> +++ b/hw/pci.c
> @@ -818,20 +818,16 @@ static const char * const pci_nic_names[] = {
>  PCIDevice *pci_nic_init(PCIBus *bus, NICInfo *nd, int devfn,
>                    const char *default_model)
>  {
> -    DeviceState *dev;
>      int i;
>  
>      qemu_check_nic_model_list(nd, pci_nic_models, default_model);
>  
>      for (i = 0; pci_nic_models[i]; i++) {
>          if (strcmp(nd->model, pci_nic_models[i]) == 0) {
> -            dev = qdev_create(&bus->qbus, pci_nic_names[i]);
> -            qdev_set_prop_int(dev, "devfn", devfn);
> -            qdev_set_prop_ptr(dev, "name", (void *)pci_nic_names[i]);

So, this patch depends on your "allow for name property" patch - resend
as a series, maybe with this one first?

> -            qdev_set_netdev(dev, nd);
> -            qdev_init(dev);
> -            nd->private = dev;
> -            return (PCIDevice *)dev;
> +            PCIDevice *d;
> +            d = pci_create_simple(bus, devfn, pci_nic_names[i]);
> +            qdev_set_netdev((DeviceState *)d, nd);

I'd prefer &d->qdev here for type safety.

Cheers,
Mark.





reply via email to

[Prev in Thread] Current Thread [Next in Thread]