|Subject:||Re: Configuration vs. compat hints [was Re: [Qemu-devel] [PATCHv3 03/13] qemu: add routines to manage PCI capabilities]|
|Date:||Mon, 15 Jun 2009 10:20:21 -0500|
|User-agent:||Thunderbird 220.127.116.11 (X11/20090320)|
Avi Kivity wrote:
I would prefer explicit names (pci_addr, lun, etc.) but would be okay with generic names too.
I think having a generic address has a lot of value in terms of code implementation. Otherwise, the valid options for -drive become context-sensitive which is going to be annoying and error-prone. Some sanity could be added by using addressing prefixes like addr=pci:00:01.0 or addr=scsi:0.3 but I'll leave that up to whoever takes this on.
Regards, Anthony Liguori
|[Prev in Thread]||Current Thread||[Next in Thread]|