[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] Keyboard issues, native DOS mode

From: Jim C. Brown
Subject: Re: [Qemu-devel] Keyboard issues, native DOS mode
Date: Tue, 14 Mar 2006 20:01:00 -0500
User-agent: Mutt/

On Tue, Mar 14, 2006 at 07:40:58PM +1100, David Burrows wrote:
> Hi all,
> This particular application, which is used to tune the aftermarket fuel 
> injection computer in my car, has a problem when running in native
> DOS mode, where two keypresses are received, instead of just the one that
> was actually pressed.  In particular I'm referring to the cursor keys.

Patch attached.

> Interestingly enough, this behaviour is not exhibited when the program is 
> run from within either win98se or win2k.

w2k (don't say win2k or win98 - see RMS on why) emulates its own kbd controller,
Hence this bus would never have manifested.

Not sure how w98 handles this but I'd guess it does emulation as well, so you
don't see the bug for the same reason.

> It might be of note that I'm using a debian sid system, but I've also 
> tried it on Ubuntu Breezy, and several others have reproduced the same 
> result.

Shouldn't matter, as it's a qemu bug so it'd be present on all versions (in fact
it'd be present when running DOS in qemu on a Windows host iiuc).

Infinite complexity begets infinite beauty.
Infinite precision begets infinite perfection.

Attachment: snadge-w.diff
Description: Text document

reply via email to

[Prev in Thread] Current Thread [Next in Thread]