qemu-block
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-block] [Qemu-devel] [PATCH] block: Make bdrv_img_create() size


From: John Snow
Subject: Re: [Qemu-block] [Qemu-devel] [PATCH] block: Make bdrv_img_create() size selection easier to read
Date: Thu, 27 Jul 2017 17:16:03 -0400
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Thunderbird/52.2.1



On 07/18/2017 12:00 PM, Eric Blake wrote:
All callers of bdrv_img_create() pass in a size, or -1 to read the
size from the backing file.  We then set that size as the QemuOpt
default, which means we will reuse that default rather than the
final parameter to qemu_opt_get_size() several lines later.  But
it is rather confusing to read subsequent checks of 'size == -1'
when it looks (without seeing the full context) like size defaults
to 0; it also doesn't help that a size of 0 is valid (for some
formats).

Rework the logic to make things more legible.

Signed-off-by: Eric Blake <address@hidden>

Reviewed-by: John Snow <address@hidden>

---
  block.c | 2 +-
  1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/block.c b/block.c
index 2dd9262cd0..57195ec40f 100644
--- a/block.c
+++ b/block.c
@@ -4398,7 +4398,7 @@ void bdrv_img_create(const char *filename, const char 
*fmt,

      /* The size for the image must always be specified, unless we have a 
backing
       * file and we have not been forbidden from opening it. */
-    size = qemu_opt_get_size(opts, BLOCK_OPT_SIZE, 0);
+    size = qemu_opt_get_size(opts, BLOCK_OPT_SIZE, img_size);
      if (backing_file && !(flags & BDRV_O_NO_BACKING)) {
          BlockDriverState *bs;
          char *full_backing = g_new0(char, PATH_MAX);





reply via email to

[Prev in Thread] Current Thread [Next in Thread]