[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: problems with mac

From: Julia Klausli
Subject: Re: problems with mac
Date: Tue, 17 May 2016 22:55:22 -0400

Hi again,

when I ran port install poppa-devel I got several error messages:
error: Failed to install python27
Please see the log file for port python27 for details:
Error: The following dependencies were not installed: python27
Error: Unable to upgrade port: 1
Error: Unable to execute port: upgrade cairo failed

when I ran the echo $PATH
I got this:
juliaklausli$ echo $PATH

I have also run the port install PSPP but I only have a folder with many files that is names PSPP 0.10.1 3 but I cannot open the actual program.

On May 17, 2016, at 1:48 PM, Friedrich Beckmann <address@hidden> wrote:

Hi Julia,

can you run 

pspp --version

in the terminal? Which version is shown?

Can you run 


in the terminal? This should open the graphical user interface. 

Could you do

echo $PATH

in the terminal and check if you have /opt/local/bin as part of the search path? If you have just installed macports, then you have to logout and login again to have the correct setting in the terminal.


Am 17.05.2016 um 19:42 schrieb Julia Klausli <address@hidden>:

Thanks. I did that and the error seems to have gone away. I have the folder with PSPP 10.1 on my computer but I can only open version 8.5 (which is what I had before but uninstalled)
Do I need to configure it or how do I get to open it?

On May 17, 2016, at 11:53 AM, Alan Mead <address@hidden> wrote:

You need to accept the Xcode license before it will work properly.  Have you tried running the recommended command ("sudo xcodebuild -license")? 

On 5/17/2016 10:46 AM, Julia Klausli wrote:
Thanks so much for your help.
Here is what I get:
Julias-MBP:~ juliaklausli$ sudo port install PSPP
Error: It seems you have not accepted the Xcode license; most ports will fail to build.
Error: Agree to the license by opening Xcode or running `sudo xcodebuild -license'.
To report a bug, follow the instructions in the guide:
Error: Processing of port PSPP failed
Julias-MBP:~ juliaklausli$ 


On May 17, 2016, at 11:26 AM, Friedrich Beckmann <address@hidden> wrote:

Dear Julia,

I have installed pspp via macports on El Capitan. Your error message refering to XCode is a hint
that something is not o.k. with the macports / Xcode install. 

Did you install XCode and the XCode Commandline Tools as discussed here:

Could you send your exact system and the exact error messages and the exact commands
that you execute?

Can you install other tools from macports? Could you execute

sudo port installed

? This will show you your already installed ports. Could you send that list?



Am 17.05.2016 um 17:01 schrieb Julia Klausli <address@hidden>:

I always get an error message stating Xcode is not working but I have installed it.
Also, I have the folder of the latest PSPP on my mac but it is not running.
Any thoughts?

Pspp-users mailing list


Alan D. Mead, Ph.D.
President, Talent Algorithms Inc.

science + technology = better workers

+815.588.3846 (Office)
+267.334.4143 (Mobile)

I've... seen things you people wouldn't believe...
functions on fire in a copy of Orion.
I watched C-Sharp glitter in the dark near a programmable gate.
All those moments will be lost in time, like Ruby... on... Rails... Time for Pi.

          --"The Register" user Alister, applying the famous 
            "Blade Runner" speech to software development

reply via email to

[Prev in Thread] Current Thread [Next in Thread]