[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Openexr-devel] Pain to install pyilmabase

From: Forum (io)
Subject: Re: [Openexr-devel] Pain to install pyilmabase
Date: Thu, 14 Dec 2017 14:46:49 +0100
User-agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:52.0) Gecko/20100101 Thunderbird/52.5.0


Thank for your reply.
I jsut tried it and I am still souspicous.

While I first tried to install boost, I enter the following command
sudo ./ --prefix=/opt/boost_1.65.1
In rder to have it installed un /opt/boost_1.65.1
sudo ./b2
to install it

Then I got a new folder in /opt/boost_1.65.1

Now I tried your suggestion (I also removed /opt/boost_1.65.1)
cd  /root/install-package/boost_1_65_1
sudo ./ --prefix=/opt/boost_1.65.1
sudo ./b2 address-model=64 variant=release threading=multi link=shared

But I do not get a the folder in /opt/boost_1.65.1 and at the end of the last command, I have this message:
The Boost C++ Libraries were successfully built!

The following directory should be added to compiler include paths:


The following directory should be added to linker library paths:


Which it mean that boost has been install in  /root/install-package/boost_1_65_1 while I want to have in /opt

Should I untar directly in /opt/boost_1.65.1 and run the command from there? So we can use a prefix (--prefix=/opt/boost_1.65.1)?

Many thank fro your help


On 12/12/17 6:51 PM, Gonzalo Garramuño wrote:

El 12/12/17 a las 11:16, Forum (io) escribió:

Thank a lot for your reply.
I am bit lost :o).

The first think, I should look at, is to share boost. I should look around the parameter -fPIC.
Also, Richard sugest to make a link Rather that a static library.

What would be the different that making a link, than sharing boost with the option -fPIC??

I downloaded and installed from this page

Then I un-tared and I "compiled" with this command:
sudo ./ --prefix=/opt/boost_1.65.1

Try the following to compile:

./b2 address-model=64 variant=release threading=multi link=shared

Address model is for x86-64.  Release is to avoid a Debug version of the library.  Threading is to make it multithreaded and link is to make it shared.
Gonzalo Garramuño

reply via email to

[Prev in Thread] Current Thread [Next in Thread]