[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: distributing Octave in August

From: John W. Eaton
Subject: Re: distributing Octave in August
Date: Fri, 15 Jun 2007 16:54:51 -0400

On 15-Jun-2007, address@hidden wrote:

| On 14:41 Fri 15 Jun     , John W. Eaton wrote:
| > On 15-Jun-2007, Olli Saarela wrote:
| > 
| > | 
| > | > However: this DVD is made possible by Emacs, which serves as the 
| > | > 'IDE' and the site of the cross-platform configuration scripts. MSVC 
Octave on 
| > | > Windows does not return a prompt to Emacs, and thus does not work.
| > | 
| > | Have you tried starting octave with
| > |   octave --interactive
| > | It works for my current setup (Octave 2.9.12-3/MSVC, Windows XP, Xemacs 
| > |   21.4.19).
| > 
| > Isn't --interactive (maybe -i) already specified in the command line
| > startup options used by octave-inf.el?
| > 
| > jwe
| --interactive worked in shell. 
| However, this appears to be  the relevant section of octave-inf.el:
| (defun inferior-octave-startup ()
|   "Start an inferior Octave process."
|     (let ((proc (comint-exec-1
|     (substring inferior-octave-buffer 1 -1)   
|     inferior-octave-buffer
|     inferior-octave-program
|     (append (list "-i" "--no-line-editing") 
|             inferior-octave-startup-args))))

OK, since -i and --interactive mean the same thing, I would expect
this to work properly.  I see:

  octave> argv
  ans =

    [1,1] = -i
    [2,1] = --no-line-editing

after running M-x run-octave in Emacs (not Windows though) so it seems
to be passing the arguments correctly.  What happens for you?  If you
are not getting a prompt, does the following work for you?

(This message was sent to the list but I don't see it in the archive.
It was held for moderator approval, but is no longer in the queue, so
I don't know what happened to it.)

  Subject: distributing Octave in August
  From: Hans Olav Husum <address@hidden>
  Reply-To: address@hidden
  To: address@hidden
  Date: Fri, 15 Jun 2007 09:47:42 +0200
  Message-ID: <address@hidden>

  >On 15-Jun-2007, poti at potis.org wrote:

  >| MSVC Octave on
  >| Windows does not return a prompt to Emacs, and thus does not work.
  >| (I would prefer the new MINGW32 binary, does that work? Where can I find
  >| it?)

  >I would not be surprised if both binaries have the same problem when
  >run from Emacs.

  This works just fine for me, using the official release of Emacs 22.1
  dowloaded from www.gnu.org and Michaels MSVC octave-package (2.9.12-3) on
  Windows XP Pro SP2.

  I did the following:

  0) Install Emacs and Octave
  1) Define an environment variable HOME pointing to what I wanted as my home
  2) Added the emacs and octave bin directories to my PATH
  3) Put my .emacs in the HOME directory
  4) Put my .octaverc in the HOME directory
  5) Added the following line to my .octaverc:

  PS1(">> ");

  My only complaint so far is that focus shifts from Emacs to the Gnuplot
  window whenever I do a plot. If anyone can suggest how to fix this I would
  be grateful.


If not, I think you will have to debug why this is not
happening.  I don't use Windows and I don't have time to do it at the
moment anyway.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]