[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Octave-bug-tracker] [bug #34885] imread() crashes

From: Bruno
Subject: [Octave-bug-tracker] [bug #34885] imread() crashes
Date: Wed, 23 Nov 2011 12:50:42 +0000
User-agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_2) AppleWebKit/535.2 (KHTML, like Gecko) Chrome/15.0.874.121 Safari/535.2


                 Summary: imread() crashes
                 Project: GNU Octave
            Submitted by: brunorberto
            Submitted on: Wed 23 Nov 2011 12:50:41 PM GMT
                Category: Libraries
                Severity: 3 - Normal
                Priority: 5 - Normal
              Item Group: Crash
                  Status: None
             Assigned to: None
         Originator Name: imread
        Originator Email: 
             Open/Closed: Open
         Discussion Lock: Any
                 Release: 3.2.4
        Operating System: Mac OS



I tried two running imread(.) on two versions of Octave: in 3.4.0, I get the
following error message:

error: imread: invalid image file: imread: image reading capabilities were
disabled when Octave was compiled

Since I don't know how to fix that (I searched for a solution but it was
overly complex, as I would have to compile the project myself and manually
enable GraphicsMagick) so I tried the 3.2.4 version available from Macports.
There, I saw a different error:

Assertion failed: (semaphore_info != (SemaphoreInfo *) NULL), function
LockSemaphoreInfo, file magick/semaphore.c, line 525.
panic: Abort trap: 6 -- stopping myself...
Abort trap: 6

This happens independently of the parameter I pass to imread (naturally a
valid image file). I tried to follow previous bug fixes but they seem similar
but not the same as  this one. I am calling this function immediately after
starting octave. 


Reply to this item at:


  Message sent via/by Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]