[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Nmh-workers] whatnow: can't attach because no header field name was

From: Ronald F. Guilmette
Subject: Re: [Nmh-workers] whatnow: can't attach because no header field name was given.
Date: Thu, 15 Mar 2012 00:53:42 -0700

In message <address@hidden>, you wrote:

>"Ronald F. Guilmette" writes:
>> Sorry.  I feel sure that this must be an FAQ, but how does one get this
>> message to go away, you know, so that I can actually send an attachment?
>Try in .mh_profile:
>send: -attach X-MH-Attachment
>whatnow: -attach X-MH-Attachment
>I actually only found out about this very recently by searching the lists.

Ummm... Well, now at least the failure message is different...

     What now? attach four-leaf.jpg
     What now? s
     mhbuild: draft shouldn't contain MIME-Version: field
     What now? 

Any other suggestions?

>It would be nice to have adding attachments work by default...

Personally, I agree that that would indeed be admirable.

P.S.  After trying your suggested fix, I realized that I wasn't sure if
you meant that I should put the "-attach X-MH-Attachment" option on the
send: or on the whatnow: or on both.  The above result is what I got when
I tried it on both (as you seemed to suggest).  since that didn't work,
I also tried it individually, first on one and then on the other.

When the option is appended to only to the send: it seems to have no effect
and I still get the "can't attach because no header field name was given."
message.  When I attached it only to the whatnow: everything _seemed_ to
work, but the e-mail message, when delivered, actually had no attachment
whatsoever. :-(

Full disclosure:  I am using NMH version 1.3.  Alas, version 1.4 has not
been ported to FreeBSD yet.  (Is this the real root of the problem?)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]