[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Nmh-workers] new TLS code doesn't build without SASL

From: Ken Hornstein
Subject: Re: [Nmh-workers] new TLS code doesn't build without SASL
Date: Thu, 16 Dec 2010 13:24:41 -0500

>> Oh, I also added TLS support for the SMTP MTA.  I tested it a bit, and
>> it seems to work fine.  SASL also works with it (but SASL encryption is
>> turned off if TLS is in use), so if you need to use TLS plus authentication
>> it should work fine.  See --with-tls and the -tls flag to send/post.
>I just tried to build nmh using --with-tls. I don't have the cyrus sasl
>stuff installed on my machine. It failed at:
>  smtp.c:1575: error: ‘sasl_complete’ undeclared (first use in this 
> function)

Whoops, my bad.  I guess I was going to test that (I had tried to make sure
that would work), but somehow I never actually _did_ it.

I just pushed a fix (along with a few others) for this.  Oliver, can you
pull down my recent changes and see if it works now?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]