[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Nmh-workers] nmh on Ubuntu

From: Josh Bressers
Subject: Re: [Nmh-workers] nmh on Ubuntu
Date: Sat, 22 Apr 2006 17:51:46 -0400

> Joel Reicher wrote:
> >> I'm getting the error "post: can't exec no: No such file or directory" when
> >> trying to send a message with nmh.
> This looks suspiciously to me as if nmh has been compiled on a system
> with no sendmail binary. Configure looks for sendmail and puts the
> sendmail path it finds in as a default value. If it can't find anything
> I think it defaults to 'no'...
> You can test this by putting 'sendmail: xyzzy' in mts.conf
> to see if the message now says 'xyzzy'. If it does, see if saying
> 'sendmail: /usr/sbin/sendmail' makes the problem go away.
> If this is the case you should report it to Ubuntu (or debian, if it's
> not been recompiled by the ubuntu guys) as a packaging bug -- it should
> Build-Depend on something that provides /usr/bin/sendmail.

This should be fixed in CVS.  I ran into this problem quite some time ago
and fixed it (it was found by a Fedora Extras nmh user).  It's a bug in the
configure script.  If configure can't find the sendmail binary, it defaults
to "no".  Now if it can't find sendmail it defaults to something sensible,


reply via email to

[Prev in Thread] Current Thread [Next in Thread]