[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Mingw-cross-env-list] gtk3 and gtkmm3

From: Nagaev Boris
Subject: Re: [Mingw-cross-env-list] gtk3 and gtkmm3
Date: Sat, 5 Sep 2015 01:59:25 +0300

On Fri, Sep 4, 2015 at 10:32 PM, Gerardo Ballabio
<address@hidden> wrote:
> Have you tried running "i686-w64-mingw32.static-nm libfreetype.a | grep
> FT_Get_BDF_Property" as I suggested? Is the symbol listed or not?
> Your list contains 256 packages. If you do a binary search, it will take 8
> rebuilds to find the offending package, if it is indeed one package. I'm
> sorry I can't help you with that. I haven't the resources to do such mass
> rebuilds.
> As another line of attack, I'd suggest that you compare the libraries built
> in the two runs. If one of those is broken in the larger build, it will be
> different from the one built by "make pango". Unfortunately a simple diff
> might not help, because I suspect that the compiler adds a timestamp or
> something else -- I remember I tried to build the same package twice and the
> two executables weren't identical. Maybe you can compare the size of the
> files.
> Now I'm going to try and build gtk3 with the files sent by the other
> submitter. I see he has posted an update, but from
> https://github.com/mxe/mxe/pull/795 I can't see where I can download the new
> version. Can you please direct me to it?

You can find a commit link in the pull request, go to "view files" and
find green button "download ZIP"

> Gerardo
> 2015-09-04 9:53 GMT+02:00 Nagaev Boris <address@hidden>:
>> On Wed, Sep 2, 2015 at 12:25 AM, Gerardo Ballabio
>> <address@hidden> wrote:
>> > I downloaded your 3-gigabytes tarball, only to find that I can't use it
>> > because it's built for 64-bits architecture, mine is 32-bits.
>> >
>> > Instead, I found that the missing symbol listed in the original report
>> > is
>> > defined in libfreetype.a:
>> >
>> > $ ./usr/bin/i686-w64-mingw32.static-nm
>> > usr/i686-w64-mingw32.static/lib/libfreetype.a | grep FT_Get_BDF_Property
>> > 00000090 T _FT_Get_BDF_Property
>> >
>> > If that symbol isn't present in your build of libfreetype.a, then the
>> > problem is with freetype-bootstrap. Please check.
>> >
>> > I extracted the freetype source tree and found that FT_Get_BDF_Property
>> > is
>> > indeed declared in include/ftbdf.h and defined in file src/base/ftbdf.c.
>> > There don't seem to be any conditional compiler directives in those
>> > files,
>> > so I can't see why that function would not be compiled.
>> >
>> > I compared your build sequence with that produced by "make pango", in
>> > order
>> > to see if I could spot any missing dependencies. But in fact, "make
>> > pango"
>> > builds *less* packages before freetype-bootstrap (after gcc it builds
>> > only
>> > three: bzip2, zlib and libpng). Could it be that freetype-boostrap needs
>> > to
>> > be built *before* some of the other packages (that would make it a
>> > dependency of the other package, instead of the other way around)? I
>> > can't
>> > quite understand why it would be so, but here's the list, in case you
>> > want
>> > to try:
>> >
>> > xz pixman pcre lzo libsigc++ libiconv libffi jpeg icu4c expat
>> > libjpeg-turbo
>> > libxml2 gettext tiff jasper dbus
>> I have built pango with `make pango` [1] and compared the log with the
>> log of build-pkg [2]
>> Here is the list of extra packages which are built by build-pkg before
>> pango and aren't build by `make pango`:
>> a52dec alure apr apr-util armadillo aspell assimp atk atkmm bfd blas
>> boost box2d bullet cairomm cblas ccfits cfitsio check chipmunk
>> cminpack cppunit crystalhd cunit curl dcmtk dlfcn-win32 eigen exiv2
>> faad2 fdk-aac fftw file flac flann fltk freeglut freeimage freetds
>> fribidi gc gdb gdk-pixbuf geos giflib glew glfw2 glfw3 glibmm gmp
>> gnutls gsl gsoap gstreamer gta guile hdf5 hunspell id3lib ilmbase isl
>> itk jansson jasper jpeg json-c jsoncpp json_spirit lame lapack lcms1
>> lcms lensfun levmar libaacs libarchive libbs2b libcaca libcdio
>> libcdio-paranoia libcomm14cux libcroco libdca libdnet libdvbpsi
>> libdvdcss libdvdnav libdvdread libepoxy libevent libf2c libftdi1
>> libftdi libgcrypt libgda libgdamm libgee libgeotiff libgnurx libgomp
>> libgpg_error libgsasl libgsf libharu libiberty libical libidn
>> libircclient libjpeg-turbo liblaxjson liblo liblqr-1 libltdl libmad
>> libmicrohttpd libmikmod libmng libmodplug libmpcdec libntlm liboauth
>> libodbc++ liboil libpaper libplist librtmp libsamplerate libshout
>> libsigc++ libsndfile libssh2 libsvm libunistring libusb1 libusb
>> libvpx libwebp libwebsockets libxml2 libxml++ libxslt libzip llvm
>> log4cxx luabind lua luajit matio mdbtools minizip mman-win32 mpc mpfr
>> mpg123 muparser mxml ncurses netpbm nettle nlopt nsis ocaml-core
>> ocaml-findlib ocaml-flexdll ocaml-native ocaml-xml-light ogg old
>> openal openblas opencore-amr openexr openjpeg openmp-validation
>> openssl opusfile opus pdcurses pdflib_lite pfstools physfs picomodel
>> pire plibc plib plotutils poco polarssl popt portablexdr portaudio
>> portmidi postgresql primesieve proj protobuf qdbm qtbase qt readline
>> rubberband rucksack sdl2_gfx sdl2 sdl2_image sdl2_mixer sdl2_net
>> sdl2_ttf sdl_gfx sdl sdl_image sdl_mixer sdl_net sdl_rwhttp sdl_sound
>> sdl_ttf sfml smpeg2 smpeg sox speex sqlite suitesparse taglib tclap
>> teem termcap theora tiff tinyxml2 tinyxml tre twolame vamp-plugin-sdk
>> vcdimager vidstab vigra vmime vo-aacenc vo-amrwbenc vorbis wavpack
>> wget winpcap winpthreads wxwidgets x264 xapian-core xerces xmlrpc-c
>> xmlwrapp xorg-macros xvidcore xz yasm zziplib
>> One of these packages seems to break something pango depends on.
>> [1]
>> https://gist.github.com/starius/6d4580f5d7fdc55eeb76#file-history-of-success-log
>> [2]
>> https://gist.github.com/starius/6d4580f5d7fdc55eeb76#file-history-of-failure-log
>> >
>> > I won't have time to do further work on this until the next weekend. I
>> > hope
>> > you'll get it sorted by then.
>> >
>> > Gerardo
>> >
>> --
>> Best regards,
>> Boris Nagaev


Best regards,
Boris Nagaev

reply via email to

[Prev in Thread] Current Thread [Next in Thread]