[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Mingw-cross-env-list] nsis 2.46 build fails (util.h patch)

From: Tony Theodore
Subject: Re: [Mingw-cross-env-list] nsis 2.46 build fails (util.h patch)
Date: Fri, 24 May 2013 16:25:49 +1000

On 24/05/2013, at 4:15 PM, Guhl Peter <address@hidden> wrote:
> It worked for nsis. The next to fail was portaudio. Now I forgot about stable
> and tried master.

That's a good idea, master is more likely to be "stable" as it has many bug 

> Works much better but fails at icu4c telling me "[install-
> recursive] Error 2.

Could you post the full build log?

> Trying "make" in tmp-icu4c/icu.cross ends with "bash: i686-pc-mingw32-g++: 
> command not found". But I don't know (yet) if that is the problem arising in
> the global make process too. The binary it looks for is existing in 
> mxe/usr/bin/
> but mxe/usr/bin is probably not in my search path...

Yes, you need to add that to your path. There's a shortcut for bash users, from 
the mxe directory:

$ source tools/mxe-activate

which will set your path and unset known problematic environment variables 
(also provides some completions so you can do `make ic<tab>`)



reply via email to

[Prev in Thread] Current Thread [Next in Thread]