[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Mingw-cross-env-list] sdl_mixer Mix_InitAudio won't run

From: David Bruce
Subject: Re: [Mingw-cross-env-list] sdl_mixer Mix_InitAudio won't run
Date: Sun, 2 May 2010 17:55:05 -0500

Hi Volker,

On Tue, Apr 13, 2010 at 9:04 PM, Volker Grabsch <address@hidden> wrote:

> So please try to add the following ./configure option to your
> src/sdl.mk (_not_ src/sdl_mixer.mk!):
>    --disable-pthread-sem
> Then build the libraries again ("make" or "make sdl_mixer etc.")
> and rebuild your application.
> If that still doesn't work, please replace "--disable-pthread-sem" with:
>    --disable-pthreads
> It would be very interesting for me to see whether one of these
> changes work for you.

It sounds like this is the same issue I ran into with sdl_mixer,
although I don't have any symbolic debugging output.  So, I tried
rebuilding my mingw-cross-env sdl libraries using each of the above
configure options in src/sdl.mk, and the problem was not affected
AFAICT.  Tux Typing still exits immediately at the initial call to

I brought this up on the SDL list a few weeks ago and got some useful
information, but without resolving the problem.  They asked me to
provide a small test program demonstrating the problem, which I did.
They then asked for the output of the program running under gdb.  So,
I guess I need to get gdb running on my Windows test machine?

Thanks for any insights or suggestions,

David Bruce

reply via email to

[Prev in Thread] Current Thread [Next in Thread]