[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Mingw-cross-env-list] guile

From: Tony Theodore
Subject: Re: [Mingw-cross-env-list] guile
Date: Thu, 15 Apr 2010 13:23:10 +1000

On 15 April 2010 08:02, Volker Grabsch <address@hidden> wrote:
> Tony Theodore <address@hidden> schrieb:
>> For my future reference, how do you find those make options like
>> "schemelib_DATA"? I thought configure generates the makefile and look
>> for something like --without-doc etc.
> This is a "standard trick" for me, but maybe it's really worth
> explaining.
> First, I indeed looked for a corresponding ./configure option,
> which would have been the cleanest way, but as usualy there wasn't
> any such option that worked.
> So I took a look into the Makefile.am files, but none of them really
> mentioned the docs. Usually you find documentation filenames in
> variables like "man_MANS", "dist_man_MANS", "html_DATA", "INFO_DEPS"
> or similar. Then it's pretty clear what to do.
> This case, however, needed some more investigation. First, I saw
> from the error messages that many *.doc files were put into the guile
> script that caused the trouble. That's why I had the idea that this
> might just be documentation files. The script's output was supposed
> to be written into a file "guile-procedures.texi", so I looked for
> variables that contain the filename "guile-procedures.texi", but I
> didn't find any.
> I could have further investigated on this, looking for files that
> have "guile-procedures.texi" as a dependency. But I found a faster
> way: In the aborted "tmp-guile/guile-*/libguile/" directory, I just
> ran "make" again, which immediately reproduced the error. Then I ran
> "make -d" and looked at the debug output. Now I could simply read
> that "guile-procedures.texi" was generated in order to generate
> "guile-procedures.txt", which was a direct target.
> So I searched the Makefile.am for a variable that contains this
> filename, and found "schemelib_DATA". I performed a quick test,
> still directly within the "tmp-guile/guile-*/libguile/" subdirectory:
>    make schemelib_DATA=
> which almost immediately succeeded. Then I changed "guile.mk"
> accordingly and restarted the whole guile build via "make guile",
> which also succeeded. That's it. :-)

Thanks for the explanation, you make it seem quite simple.

I'll certainly keep this in mind,


reply via email to

[Prev in Thread] Current Thread [Next in Thread]