[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Lynx-dev] Wrapping line behavior

From: Thomas Dickey
Subject: Re: [Lynx-dev] Wrapping line behavior
Date: Sun, 5 Feb 2017 18:26:47 -0500
User-agent: Mutt/1.5.21 (2010-09-15)

On Sat, Feb 04, 2017 at 12:14:15PM -0800, address@hidden wrote:
> > So... it would be nice to have a copy of these files from your configure
> > and build:
> > 
> > a) config.log
> > 
> > b) config.status
> > 
> > c) config.cache
> Could you find attached files?
> > as well as knowing what X resources you are using for kterm (as well as
> > the $TERM value -- which should be "kterm", not "xterm", since the latter
> > uses several features _not_ in kterm's repertoire).
> How can I show X resources I'm using for kterm?
> I don't use .Xresources and command line is "kterm -km euc -geometry 
> 80x25+0+0&"

then I'm still puzzled.  I ran your config.status/config.cache against
2.8.8dev.9 and 2.8.8dev.10 trees on my Ubuntu 14.04 machine, eliminated
environment variables (LYNX_CFG, TERMINFO, TERMINFO_DIRS) which might
affect the behavior, and still do not see lynx failing to wrap the lines.

kterm (like xterm) has an option to suppress the terminfo's autowrap,
but lynx (both slang and ncurses) is not relying upon that.  I captured
the output using "script", and can see that it is doing cursor-addressing
to go to the next line.

Thinking about it a little more, I tried fooling it using the $COLUMNS
environment variable (no), "stty columns" (no) and lynx's "-width" option
(still no).

See attached screenshots :-(

Thomas E. Dickey <address@hidden>

Attachment: lynx2.8.8dev.9.png
Description: PNG image

Attachment: lynx2.8.8dev.10.png
Description: PNG image

Attachment: signature.asc
Description: Digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]