[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Lynx-dev] Fwd: Lynx color support broken by update

From: David Vergnaud
Subject: [Lynx-dev] Fwd: Lynx color support broken by update
Date: Fri, 4 Sep 2015 08:30:04 -0400

Hi devs,

a compatibility problem has been found recently between lynx-2.8.8rel.2 and ncurses 6 in the macports version. I’m including the thread below. 



On Thu, 3 Sep 2015, Ryan Schmidt wrote:

Same Lynx version on FreeBSD works OK, so Macports' is busted.

Does FreeBSD use ncurses 5 or 6?

Aha!  It's (currently) using 5.9 (I did see that later reply).  So yep, it 
appears to be a problem with the way that Lynx uses Ncurses 6.

And I can't figure out what version of Ncurses that Lynxlet uses (I'm used 
to genuine BSD systems, not the Mac version).

On Thu, 3 Sep 2015, David Vergnaud wrote:

So now I'm annoyed that lynx got broken and surprised that the situation 
doesn't seem consistent.

Hmmm...  Busted here too (2.8.8rel.2 on 10.10.5).

Lynxlet still works, though, but I can't tell what version it is.

Same Lynx version on FreeBSD works OK, so Macports' is busted.

On Sep 3, 2015, at 10:05 AM, David Vergnaudwrote:

I've just run a "port upgrade outdated" on my Yosemite 10.10.5 iMac. Quite honestly, I can't remember when was the last time I did, but I think it can't have been that long since I got the Mac only a few months ago and that's got to be when I first installed MacPorts. Still, it did some updates, amongst which lynx, taking it to version 2.8.8rel.2, which is weird because it says the version is from March 09 2014. 

Not weird: ncurses was updated to version 6 on August 17, 2015, which necessitated rebuilding all ports that use ncurses, which includes lynx.

Anyway, lynx used to be working fine with the previous version (looking at another Mac that hasn't been updated, it was probably 2.8.7rel.1), now however it seems the color/style support has been broken: pages are displayed with only white text on black background, no highlighting of any kind, no active link. I've tried to enable the "Show cursor" option in the in-app Options but that didn't have any effect. I've tried specifying the lss file (/opt/local/etc/lynx.lss) on the command line but that didn't do anything either. 

Also, looking at the release notes (, there seems to be an option -default-colors available in 2.8.8, and I was thinking this might have an effect, but it doesn't seem to work either, the option is not recognized :-(. 

So now I'm annoyed that lynx got broken and surprised that the situation doesn't seem consistent. I'm wondering what my options are and if someone has answers to the following questions: 
- is there a way to fix my currently installed version? 
- is it possible to revert to the previous version of lynx using macports? 
- if ever I get it to work again, does anyone know of a way to toggle between colored/non-colored mode within lynx? Some sites are displayed using e.g. dark blue which isn't really readable on a dark background. 

I am not very familiar with lynx, and was not aware how it was supposed to use color. But it is possible that lynx is using ncurses to do colors, and that it is using ncurses in a way that worked with ncurses 5 but not with ncurses 6.

I verified that the current version of lynx, @2.8.8rel.2_1, which is build with ncurses @6.0_0, shows as white text on a black background (default colors for my terminal).

I then backdated my ncurses and lynx ports and installed ncurses @5.9_2 and lynx @2.8.8rel.2_0, and verified that now shows colors: the title text is purple, links are in green while the select link is in yellow, some other text is red, and the bar at the bottom of the window uses yellow text on a blue background.

I'm Cc'ing the maintainer of the lynx port, but since the only change has been the version of ncurses, this suggests a bug in lynx, and the problem should be reported to the developers of lynx so that they can resolve it and release a fixed version.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]