[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Lynx-dev] lynx not working on new Mac

From: Matthew Yasner
Subject: Re: [Lynx-dev] lynx not working on new Mac
Date: Wed, 6 Feb 2013 14:38:19 -0800

Thank you both for the speedy responses. My iMac's Hardware Overview reads:

  Model Name:    iMac
  Model Identifier:    iMac13,2
  Processor Name:    Intel Core i7
  Processor Speed:    3.4 GHz
  Number of Processors:    1
  Total Number of Cores:    4
  L2 Cache (per Core):    256 KB
  L3 Cache:    8 MB
  Memory:    16 GB
  Boot ROM Version:    IM131.010A.B04
  SMC Version (system):    2.11f14

I just went into the directory where lynx is stored (/usr/local/bin) and tried to run that program. Unfortunately, I get the same message:

-bash: ./lynx: Bad CPU type in executable

Maybe I've downloaded an older version. The download I'm installing is:

I'm running Mac OS X 10.8.2.

It's not crucial immediately, but it would be nice to find out what's wrong and to get it to work.

Thanks again,

P.S. I'm only a novice when it comes to Unix. I can execute some terminal functions, but I've never written or compiled a program.

On Wed, Feb 6, 2013 at 2:04 PM, Nelson H. F. Beebe <address@hidden> wrote:
Here is what I see on PowerPC and Intel-based Mac OS X systems:

        % file $B/lynx
        /usr/local/bin/lynx: Mach-O executable ppc

        % file $B/lynx
        /usr/local/bin/lynx: Mach-O executable i386

It is possible to build fat binaries on either system that will run on
both, though build attempts that way seem to fail for most packages.

Here are Makefile assignments that I use for such builds:

        CC      = "cc -arch ppc -arch ppc64 -arch i386 -arch x86_64"
        CXX     = "c++ -arch ppc -arch ppc64 -arch i386 -arch x86_64"
        LDFLAGS = -L/usr/local/lib64
        libdir  = /usr/local/lib64

I just tried such a build of lynx2-8-7 on Mac OS X 10.7.5 (Intel),
which has the clang-based /usr/bin/cc; it failed, apparently because
of the lack of cross-platform code generation.

GNU autoconf-generated configure scripts seem to choke on the
fat-binary settings, so on an older PowerPC Mac OS X 10.5.8 system,
I tried this workaround:

        % env CC=cc ./configure

        % make CC="cc -arch ppc -arch ppc64 -arch i386 -arch x86_64"

        % file lynx
        lynx: Mach-O universal binary with 4 architectures
        lynx (for architecture ppc7400):        Mach-O executable ppc
        lynx (for architecture ppc64):  Mach-O 64-bit executable ppc64
        lynx (for architecture i386):   Mach-O executable i386
        lynx (for architecture x86_64): Mach-O 64-bit executable x86_64

        ./lynx --version
        Lynx Version 2.8.7rel.2 (21 Jun 2010)
        libwww-FM 2.14, ncurses 5.5.20051010
        Built on darwin9.8.0 Feb  6 2013 14:59:30

Success!  [I tested the executable on the Intel-based Mac, and got
identical output.]

If someone is interested in a private distribution of that build,
please contact me directly off list.

- Nelson H. F. Beebe                    Tel: +1 801 581 5254                  -
- University of Utah                    FAX: +1 801 581 4148                  -
- Department of Mathematics, 110 LCB    Internet e-mail: address@hidden  -
- 155 S 1400 E RM 233                       address@hidden  address@hidden -
- Salt Lake City, UT 84112-0090, USA    URL: -

Managing Editor
Dermatology Online Journal
reply via email to

[Prev in Thread] Current Thread [Next in Thread]