[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Lynx-dev] lynx2.8.7pre.1 build problem

From: Virden, Larry W.
Subject: [Lynx-dev] lynx2.8.7pre.1 build problem
Date: Wed, 22 Apr 2009 13:33:06 -0400

I am trying to build the latest 2.8.7 source distribution and I am
having a problem understanding what I need to do.

I configure the source. I run the gmake. I get a lynx. However, more is
being built, as I am seeing

gmake[1]: Entering directory
Compiling Lynx sources
cd chrtrans && gmake \
                SITE_DEFS="" \
                BUILD_CFLAGS="-g -Xa -xtransition -xarch=v9 " \
-I/projects/gnu/sparc-sun-solaris2.9/include -D__EXTENSIONS__
-I/projects/intranet/ssl/include/openssl -DHAVE_CONFIG_H" \
                BUILD_LDFLAGS="" \
                BUILD_LIBS="" \
                BUILD_CC="cc" tables
gmake[2]: Entering directory
gmake[2]: Nothing to be done for `tables'.
gmake[2]: Leaving directory
cc -DHAVE_CONFIG_H  -DLOCALEDIR=\"/projects/intranet/share/locale\" -I.
-I.. -Ichrtrans -I/home/lwv27/i/src/Unix/lynx/t/lynx2-8-7/src/chrtrans
-I/projects/gnu/sparc-sun-solaris2.9/include -D__EXTENSIONS__
-I/projects/intranet/ssl/include/openssl -g -Xa -xtransition -xarch=v9
-c LYShowInfo.c
Utils.h", line 534: missing operand
Utils.h", line 572: missing operand
cc: acomp failed for LYShowInfo.c
gmake[1]: *** [LYShowInfo.o] Error 2
gmake[1]: Leaving directory
gmake: *** [all] Error 2

When I take a look at line 534, I see

 * Printing/scanning-formats for "off_t", as well as cast needed to fit.
#if defined(HAVE_INTTYPES_H) && defined(SIZEOF_OFF_T)
#if (SIZEOF_OFF_T == 8) && defined(PRId64)

(pointing at the PRId64) line

And when I look at line 572, I see:

 * Printing-format for "time_t", as well as cast needed to fit.
#if defined(HAVE_INTTYPES_H) && defined(SIZEOF_TIME_T)
#if (SIZEOF_TIME_T == 8) && defined(PRId64)

This is using Sun's Forte C compiler. I tried splitting the if into 2
#if's, and I get the same error with the line
#if (SIZEOF_OFF_T == 8)

Looking more, I wonder if SIZEOF_OFF_T is an empty string. That would
certainly explain the error that I am seeing.
I don't, however, know why .

Looking through the config.log, I see:

configure:34144: cc -c -g -Xa -xtransition -xarch=v9
clude -I/projects/gnu/sparc-sun-solaris2.9/include -D__EXTENSIONS__
intranet/ssl/include/openssl -DHAVE_CONFIG_H -I.
/lynx2-8-7 -I/home/lwv27/i/src/Unix/lynx/t/lynx2-8-7/src
x/lynx/t/lynx2-8-7/WWW/Library/Implementation conftest.c >&5
"conftest.c", line 1: warning: 34130 is invalid in #line directive
"./lynx_cfg.h", line 56: warning: macro redefined: GETGROUPS_T
"./lynx_cfg.h", line 225: warning: macro redefined: SIZEOF_INT
"./lynx_cfg.h", line 226: warning: macro redefined: SIZEOF_LONG
"./lynx_cfg.h", line 227: warning: macro redefined: SIZEOF_OFF_T
"./lynx_cfg.h", line 228: warning: macro redefined: SIZEOF_TIME_T

And later

#define SIZEOF_OFF_T 

As well as:

$ grep SIZEOF_OFF_T *.h
cfg_defs.h:     { "SIZEOF_OFF_T",       "" },
lynx_cfg.h:#define SIZEOF_OFF_T                 /*
srv29 (59568) $ 

So it looks like something isn't working quite right, using Sun's c

<URL: >
Even if explicitly stated to the contrary, nothing in this posting
should be construed as representing my employer's opinions.
<URL: mailto:address@hidden > <URL:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]