[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Fwd: [Lynx-dev] lynx not honoring apache document root path

From: Thomas Dickey
Subject: Re: Fwd: [Lynx-dev] lynx not honoring apache document root path
Date: Mon, 16 Jul 2007 06:04:20 -0400 (EDT)

On Mon, 16 Jul 2007, Hendrik-Jan Heins wrote:

---------- Forwarded message ----------
From: Hendrik-Jan Heins <address@hidden>
Date: 15 jul. 2007 23:11
Subject: Re: [Lynx-dev] lynx not honoring apache document root path
To: Thomas Dickey <address@hidden>


You seem to be right; it is something with apache.
I just tried lynx on my local machine with apache (debian Sid), and
there it all worked.
Do you have any idea how to proceed to find out what's happening here?

sorry - I have only a rough knowledge of Apache.
(at the moment I'm deep in an xterm change).

I had in mind to approach this by looking to see if I could find when/why
the leading "/" for a GET of a query is optional (or not).

With some checking, I can see that it's more complicated than that:
just skipping the "/" for that GET is still leaving a newline in the
query which appears to confuse the server:

HTTP: Not sending authorization (yet).
GET query_part.php?brandname=

The reason for the slash is because lynx has decided that it needs an absolute reference in this case.


2007/7/15, Thomas Dickey <address@hidden>:
On Sun, 15 Jul 2007, Hendrik-Jan Heins wrote:

> Hello list,
> I just stumbled upon a really weird problem with lynx:
> There is this website:
> If you go there with lynx, choose for instance the first brandname of
> the list, and submit the query, you get an Apache2 error message of


Server: Apache^M
X-Powered-By: PHP/4.4.4-8+etch4^M
Set-Cookie: linux-wless[]=Linux+wireless+website; expires=Sun, 15 Jul 2007
Set-Cookie: PHPSESSID=76ed6786a72b819562c829a5200cc0b4; path=/^M
Expires: Thu, 19 Nov 1981 08:52:00 GMT^M
Cache-Control: no-store, no-cache, must-revalidate, post-check=0,
Pragma: no-cache^M
Connection: close^M
Content-Type: text/html; charset=utf-8^M

(something odd about that 1981).

> the fact that the link you just requested, doesn't exist.
> The weird thing is:
> - the link does exist, and all other browsers I tried, do know how to
> "find" it (firefox, seamonkey, konqueror, elinks, links).

w3m also (which counts more than any of the (e)links(2) variants).

> - lynx is looking for the file in completely the wrong place, namely
> in the root of Apache, not in the root of the domain.
> - It seems that lynx by itself adds a "/" to the name of the file
> - this only seems to happen with links that are <name>.php files and
> not with <name>.html files, as those links work fine

Actually the "GET" in each case puts a "/" in front, whether it's a php
file or a html file.  You can see that in the trace file using

        lynx -trace

(Whether that's correct or a misfeature/misconfiguration of Apache, I'm
not sure at the moment).

> I've tried this with several versions, among which:
> Lynx Version 2.8.6rel.4
> Lynx Version 2.8.5rel.1
> Could you please shed some light on this?
> Thanks,
> Hendrik-Jan
> _______________________________________________
> Lynx-dev mailing list
> address@hidden

Thomas E. Dickey

Lynx-dev mailing list

Thomas E. Dickey

reply via email to

[Prev in Thread] Current Thread [Next in Thread]