[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Lynx-dev] lynx not honoring apache document root path

From: Hendrik-Jan Heins
Subject: Re: [Lynx-dev] lynx not honoring apache document root path
Date: Mon, 16 Jul 2007 08:54:35 +0200

I tried it without the target="_parent" line, but that makes no
difference. I still get the same error message.
(You can test it yourself, the query for the brandname is now without
the target defiition).


2007/7/16, Stefan Caunter <address@hidden>:

On 7/15/07, Hendrik-Jan Heins <address@hidden > wrote:

> There is this website:
> If you go there with lynx, choose for instance the first brandname of
> the list, and submit the query, you get an Apache2 error message of
> the fact that the link you just requested, doesn't exist.
> The weird thing is:
> - the link does exist, and all other browsers I tried, do know how to
> "find" it (firefox, seamonkey, konqueror, elinks, links).
> - lynx is looking for the file in completely the wrong place, namely
> in the root of Apache, not in the root of the domain.
> - It seems that lynx by itself adds a "/" to the name of the file
> - this only seems to happen with links that are <name>.php files and
> not with <name>.html files, as those links work fine
> I've tried this with several versions, among which:
> Lynx Version 2.8.6rel.4
> Lynx Version 2.8.5rel.1
> Could you please shed some light on this?

The target="_parent" tag seems to be relevant; it wants to open a page
inside a frameset, which isn't possible since lynx doesn't know about it.
Look at the output of lynx -trace, the request seems to get sent as:

Composing Authorization for

HTAASetup_lookup: No template matched `query_part.php?brandname=
' (so probably not protected)
HTTP: Not sending authorization (yet).
GET /query_part.php?brandname=

I didn't add in the line wrap where brandname=2Wire is split (not sure why
that is there - I'm using putty). I thought it might have been some js in
there, but it's just that _parent tag and it really seems like the server is
responding correctly.

Stefan Caunter

reply via email to

[Prev in Thread] Current Thread [Next in Thread]