[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Compiling MingW lynx under Cygwin (was Re: [Lynx-dev] text browsing)

From: Doug Kaufman
Subject: Re: Compiling MingW lynx under Cygwin (was Re: [Lynx-dev] text browsing)
Date: Sat, 12 Aug 2006 18:21:58 -0700 (PDT)

On Sat, 12 Aug 2006 address@hidden wrote:

> On Sun, 30 Jul 2006, address@hidden wrote:
> > On Sat, 29 Jul 2006 address@hidden wrote:
> > 
> > OK. I went back through my notes and patches and did some more testing.
> > Here is a step-by-step guide to building a statically compiled lynx
> > under Cygwin which will not be dependent on the cygwin dll (i.e. a MingW
> ...
> I tried it and finally successed to build with some efforts.
> I wrote some comments and questions below.
> >              Compiling lynx for MingW under Cygwin
> > 
> I want to use precompiled libraries if it's OK.
> If I should to use patched libraries, please tell me which libraries
> sould be patched.

I would presume that the precompiled libraries are OK until proven
otherwise. I didn't look for precompiled libraries, so I am not certain
how the patches that they used to compile for MingW differed from what I
posted. To keep the binary file compatible with Win98, I would try to
ascertain that they are not dependent on any system files only available
with WinNT/Win2K/WinXP.

> > ...
> > 1. Compile and install MingW PDCurses 2.8
> I used precompiled library: pdcurses-2.6.0-2003.07.21-1.exe
> I got from

When I put together the guide, I had forgotten to mention the patch
necesary to make lynx function with PDCurses 2.7 or 2.8. By using 2.6,
you avoid the need for that patch (which I hope will be included in

> > 2. Compile and install MingW OpenSSL 0.9.8 stable branch
> I tried GnuTLS instead of OpenSSL.
> I used precompiled library:
> I got from

OpenSSL uses the environment variable SSL_CERT_FILE to indicate where
the collection of trusted certificates resides. How does GnuTLS find the
file if it isn't in the default location which was compiled in?

> > 3. Compile and install MingW iconv
> > 
> > I used libiconv 1.8.
> > I applied this patch:
> I used precompiled library:
> I got from
> > 4. Compile and install MingW gettext 
> > 
> > I used gettext-0.11.5.
> > I applied this patch:
> I used precompiled library: gettext-0.11.5-2003.02.01-1.exe
> I got from
> # I found two different source archives of gettext-0.11.5 from
> #
> #
> # 
> # I failed to apply your patch to the former one.
> # I successed to apply it the latter one but haven't successed to built.

On the version that I compiled, the character set conversion worked
correctly in fullscreen mode, using the DOS codepages, for all
combinations that I tried, but sometimes gave wrong characters in
windows mode. I'll try again with the latest versions (gettext-0.15 and
libiconv-1.11 to see if that makes any difference.

> > ...
> > #!/bin/bash.exe
> > LDFLAGS="-mno-cygwin -static" \
> > LIBS="-L/mingw/lib -lwsock32 -lgdi32 -lmsvcrt -liconv" \
> I think "-L/mingw/lib" should be in LDFLAGS instead of in LIBS.

That should work.

> I changed these line as below to compile with GnuTLS.
>     LDFLAGS="-mno-cygwin -static -L/mingw/lib" \
>     LIBS="-lgdi32 -lmsvcrt -liconv -lgcrypt -lgpg-error -lwsock32" \
> # I don't know why I have to add "-lgcrypt -lgpg-error".

I dont' have those libraries on my machine. Are they bundled with


Doug Kaufman
Internet: address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]