[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Lynx-dev] compile error under Cygwin (was: lynx2.8.6dev.18)

From: Thomas Dickey
Subject: Re: [Lynx-dev] compile error under Cygwin (was: lynx2.8.6dev.18)
Date: Fri, 2 Jun 2006 13:16:20 -0400
User-agent: Mutt/1.3.27i

On Sat, Jun 03, 2006 at 02:08:57AM +0900, address@hidden wrote:
> On Wed, 31 May 2006, address@hidden wrote:
> > On Thu, 1 Jun 2006, address@hidden wrote:
> > 
> > > I tried to compile 2.8.6dev.18 under Cygwin environment but failed.
> > >
> > > First, I failed to compile HTTCP.c.  It's improved after applying a
> > > patch which is attached to this mail.
> > >
> > > Second, I failed to link with these messages.
> > 
> > I saw the WSaSetLastError in your earlier patch, but did not see why you 
> > needed it.  Is this a recent change to cygwin (or have you not installed 
> > win32api, which I seem to recall is the interface needed)?
> Thanks for your comment.  I've installed win32api 3.7-1 already.
> I also tested with win32api 3.6-1 and 3.5-1 but got the same result.
> I can't imagine the reason at all.

I'm not sure either.  When I was looking at the proposed patch, I looked
rather briefly and saw that symbol declared in win32api.  I didn't try
building without the package installed to verify this.  I'll investigate
further and try to find a possible cause.
> > (I'm using cygwin installed from a snapshot from last winter).

Thomas E. Dickey

reply via email to

[Prev in Thread] Current Thread [Next in Thread]