[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Lynx-dev] Lynx-Win32 scroll bars (was: Re: lynx)

From: Jeff
Subject: Re: [Lynx-dev] Lynx-Win32 scroll bars (was: Re: lynx)
Date: Sun, 09 Jan 2005 14:19:51 -0600
User-agent: Opera M2(BETA1)/8.00 (Win32, build 7401)

On Sun, 9 Jan 2005 11:35:16 -0800 (PST), Doug Kaufman <address@hidden> wrote:

On Sun, 9 Jan 2005, Webmaster Jim wrote:

I distribute a Win32 build of Lynx 2.8.5, and can't answer the attached
questions off the top of my head. Are scroll bars X specific? Does LSS
get included in Win32? I used the usual Lynx/Borland build file, IIRC.

> Jeff Pruet wrote:
> Is this build not compiled to use scrollbars? Because I can't get it to > work with the -scrollbar flag. Lynx just shows the arg list and exists. > And changing the cfg file doesn't help. Also, lynx -lss \set LYNX_LSS=
> won't let me use a custom lss file, even the examples.

The scrollbar is considered "experimental" and isn't compiled by
default. You would have to add "-DUSE_SCROLLBAR" to your CFLAGS when
compiling. It should work with ncurses or pdcurses. I haven't used it
myself when I compile mingw version, but I can try it when I next do a
mingw build

The lss files only apply for a color-style build. In the Borland
makefile, you would have had to uncomment CS_DEFS and CS_OBJS if you
wanted to build a color-style version. It doesn't appear to be the
default. To check the executable (assuming it isn't compressed), you can
do "strings lynx.exe" and search for the string "LYNX_LSS". If it isn't
there, you didn't build with color-styles.

The problem with the lss file may also be wrong syntax. You can either
do: "lynx -lss=c:/programs/lynx/mylssfile.lss" or set an environment
variable: "set LSS=c:/programs/lynx/mylssfile.lss". This works fine in
my mingw build. With the Borland build, do you need to use forward
slashes in the file path or will backslashes work also? It isn't clear
from Jeff's note exactly what syntax he tried.

I tried both ways. Specifically, 'lynx -lss=c:/jeff/net/lynx_w32/samples/lynx.lss' caused lynx to show the arg list and then exit, like 'lynx -help'. But, I just now did 'lynx -help
flags.txt' and saw that I don't have the -scrollbar/-lss flags. So I
don't think the build at was compiled to use lss/scrollbars. Sorry for the distraction.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]