[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Lynx-dev] Configure script (AC2.52) broken for DJGPP (2.8.6dev.4)

From: Doug Kaufman
Subject: [Lynx-dev] Configure script (AC2.52) broken for DJGPP (2.8.6dev.4)
Date: Mon, 21 Jun 2004 09:13:10 -0700 (PDT)

The configure script that ships with lynx2.8.6dev.4 doesn't work with
DJGPP. It does work with MingW when using cygwin and -mno-cygwin. The
problem seems to be that the DOS path is not handled properly, so that
none of the binary files needed for configure to run can be found.
Comments in the packages of the DJGPP ports of autoconfig indicate
that configure scripts generated with the DJGPP port should work in
unix or DOS, but that scripts generated with the autoconfig 2.5x
series on unix may not work in DOS.

I tried regenerating the configure script using the DJGPP ports of
autoconfig. The only ones officially ported are 2.13, 2.50, and 2.57. I
also tried to port 2.52 and 2.59 to DOS and use those versions. The 2.13
version works and produces a makefile that gives a working binary of
lynx. The 2.57 and 2.59 versions (patched with Tom's patch for 2.57)
handle the DOS path, but don't handle the AC_DIVERT_HELP macro from the
patch. This doesn't get evaluated and shows up as the macro name in the
configure script. The 2.52 version handles the AC_DIVERT_HELP macro OK,
but doesn't handle the DOS path. Perhaps I haven't found the right way
to patch 2.52 for DOS yet. The 2.13.20020210 version works OK. I haven't
tried yet with the latest patch (20030927).

Tom, do you think you might have a chance to look again at the 2.57
patch? I tried to fix it, but couldn't figure out why the
AC_DIVERT_HELP macro worked in 2.52 but not in 2.57. If we want DJGPP to
work well with lynx, and want to use the 2.5x series of autoconfig, the
patch for 2.57 probably needs to be updated.

Doug Kaufman
Internet: address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]