[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: lynx-dev gettext troubles

From: Doug Kaufman
Subject: Re: lynx-dev gettext troubles
Date: Fri, 24 Oct 2003 20:28:31 -0700 (PDT)

On Sat, 25 Oct 2003, Henry Nelson wrote:

> > And I've tried with LOCALEDIR or $LYNX_LOCALEDIR:
> >   g:/MingW32/share/locale
> >   /MingW32/share/locale
> >   /g/MingW32/share/locale
> And on my system, where gettext is in fact functional within Lynx, none
> of those would work.  Unless something is different between the gettext
> package you are using and the one I am using (gettext-0.10.35, for a long
> time the only decent gettext package, but now obsoleted by the most recent
> GNU gettext which is closely integrated with iconv), the final "locale"
> should not be there.  On Solaris8, Solaris6, NetBSD1.4.3 and NetBSD1.5.2
> with Lynx 2.8.5dev.16 or Lynx 2.8.4dev.15 I run the configure script with
> the option --with-nls-datadir=/path/from/root/share.  Under that directory
> "share" (it can be any name, not just share) I have "locale/ja/LC_MESSAGES/
>", and it `` just works ''.  It isn't just Lynx; I also use Mutt
> daily with a Japanese message catalogue, although in this case the
> file is in the default directory "/usr/local/share/locale/ja/LC_MESSAGES",
> so it's no real test.

I think you are mixing up NLS_DATADIR and LOCALEDIR. LOCALEDIR is
defined as $NLS_DATADIR/locale. See src/ for the
relationship. "configure" defines NLS_DATADIR, then LOCALEDIR is defined
in src/makefile. So NLS_DATADIR doesn't have the finale "locale", while

Doug Kaufman
Internet: address@hidden

; To UNSUBSCRIBE: Send "unsubscribe lynx-dev" to address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]