[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

lynx-dev Trouble using file upload

From: Mark Wainwright
Subject: lynx-dev Trouble using file upload
Date: Sun, 15 Dec 2002 14:37:54 +0000 (GMT)

I'm probably doing something very stupid, but I can't seem to get file
upload to work. That is, I visited


which has an <input type=file>, selected the relevant input, typed in
the name of a suitable test file (in the current directory; I also tried
giving the full path name) and submitted the form. I got an error
message telling me I hadn't submitted a file at all. Lynx clearly thinks
it's able to handle the file input since it encourages me to enter a
file name, and I found hints in the lynx-dev archives that it's worked
happily for people in the past, so I'm not sure what I'm doing wrong.
The lynx documentation on forms doesn't seem to mention file inputs.

Notes that may or may not be useful:

1. The file entry field wasn't automatically activated, unlike other
text entry fields.

2. lynx -version says

  Lynx Version 2.8.4rel.1 (17 Jul 2001)
  Built on linux-gnu Oct 15 2002 12:59:31

but I get the same behaviour from version 2.8.3rel1 on Irix 6.3.

Speaking of which, how am I running version 2.8.4 when
<> thinks the latest version is 2.8.3?

A final query: since lynx can do file browsing, wouldn't it be splendid
if it could use this capability to help choose a file for file input?


Mark Wainwright

; To UNSUBSCRIBE: Send "unsubscribe lynx-dev" to address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]