[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: lynx-dev Table troubles

From: Thomas E. Dickey
Subject: Re: lynx-dev Table troubles
Date: Mon, 26 Feb 2001 08:03:50 -0500 (EST)

On Sun, 25 Feb 2001, Robert Mognet wrote:

> Hello,
> Using lynx2.8.4dev.18 with patch-lynx2.8.4dev.18c-p1 applied.
> Trying to access the following URL: (34580 bytes)
>       <>
> causes lynx to eat all the machine's memory.

I tried this and saw it max-out at 80Mb (seemed to be in some sort of
infinite loop).  My impression is that it's trying to iterate toward
the proper configuration of the tables, but isn't converging - either
an error in the algorithm, or not efficient.  (After dev.19, I'll
see if it would be not be too hard to maintain old/new TRST's ifdef'd)

> The kernel complains:
> "VM: do_try_to_free_pages failed for [all running processes]"
> accompanied by lots of disk thrashing - I assume the kernel is
> trying to swap everything it can.  Interrupting lynx with 
> ctrl-C eventually works and after a while things settle down.
> Have tried several times with the same result.
> Retrieving the file with wget and looking at the html, the
> page is composed of one large table containing three inner tables.
> Regards,
> Robert
> ; To UNSUBSCRIBE: Send "unsubscribe lynx-dev" to address@hidden

T.E.Dickey <address@hidden>

; To UNSUBSCRIBE: Send "unsubscribe lynx-dev" to address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]