[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

lynx-dev SSL, VMS and MMS (actually MMK)

From: system
Subject: lynx-dev SSL, VMS and MMS (actually MMK)
Date: Fri, 21 Jul 2000 13:01:22 -0600


installed and logicals defined

  DIGITAL TCP/IP Services for OpenVMS Alpha Version V5.0A
  on a AlphaServer 1000A 4/266 running OpenVMS V7.2

downloaded the new files for ssl support:
HTAAUTIL.C;2        HTFORMAT.C;2        HTNEWS.C;2          HTTP.C;2

I couldn't find the RSA library.  Yeesh, now I can't even find the
URL for getting the library.

My understanding was that that library is only necessary for certain
types of cryptography.

In any case I tried building it using MMK and it died on the link,
with lots of errors concerning undefined symbols in gridtext.obj.
They were defined in trstable which hadn't been compiled so I
manually compiled [LYNX2-8-3.SRC]trstable.c and linked everything 

I wasn't watching the original compile closely, so I don't know
if there was an error compiling it, but the [LYNX2-8-3.SRC]descrip.mms
does not list trstable.obj in its list of objs.

I know next to nothing about mmk or make so ...

Having linked it the executable worked fine.  I had fun playing
with the table support.  Found that if I had a table cell
with <br>s in it that I had to surround it with <p align=left> 
and </p> otherwise it centers each line, which (IMHO) looks
lousy and (IME) is harder to read.

That aside it is nice to see decent table support.

However... my compile does not successfully access https URLs.

I am guessing that the problem occurs because of changes to

the ssl version of which has the following:

SSL_DIR= /usr/local/ssl
SSL_LIBS= -L$(SSL_DIR)/lib -lssl -lcrypto
SSL_DEFINES= -DUSE_SSL -I$(SSL_DIR)/include/openssl -I$(SSL_DIR)/include

SITE_LIBS= $(SSL_LIBS) # Your libraries here
SITE_LYDEFS = $(SSL_DEFINES) # Your defines here
SITE_DEFS = $(SSL_DEFINES) # Your defines here

In which the $(SSL...) are new.

I would guess the first three need to be changed to:

SSL_LIBS= -LSSLLIB -lssl -lcrypto

Where SSLEXE, SSLLIB and SSLINCLUDE are VMS logicals.
(there is no ssl_dir/include/openssl)

But I don't think mmk makes any use of the makefiles.

Any suggestions?

Robert Morphis

; To UNSUBSCRIBE: Send "unsubscribe lynx-dev" to address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]