[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

lynx-dev Re: lynx 2.8.2 not working on AIX 3.2.5

From: Klaus Weide
Subject: lynx-dev Re: lynx 2.8.2 not working on AIX 3.2.5
Date: Fri, 7 Jan 2000 12:46:10 -0600 (CST)

On Thu, 6 Jan 2000, Denny Watkins wrote:

> Klaus,
> Something of interest:
> I still have the executable for lynx2-7-1
> So I tried the following from where the executable is located:
> ./lynx file://localhost/usr/morn/bin/XX

> No pressing of keys to get the entire file read!!!
> This looks 'normal' for a local file.
> So I tried the following:
> ./lynx -cfg=/home/watkins/ftps/lynx2-7-1-exe/usr/local/lib/lynx.cfg
> get the following message:
> Alert!: Unable to connect to remote host.
> lynx: Can't access startfile

> ./lynx2-3.AIX.EXE -cfg=./lynx.cfg file://localhost/usr/morn/bin/XX
> This also works great for local files.
> but
> ./lynx2-3.AIX.EXE -cfg=./lynx.cfg
> cannot connect:
> Alert!:  Unable to connect to remote host.

It seems you are having two distinct problems.  They may or may not
be directly related.

1) Lynx stalls - it's willing to do something only if you push it
  (press a key).  Only with your newly compiled 2.8.2.

2) Lynx cannot establish a TCP connection.  All your Lynx binaries
   (ald and new) have this problem.

Is that summary correct?

As for problem 1 -
It looks related to the function HTCheckForInterrupt.  Could you please
try the following: In file src/LYUtils.c, find

  PUBLIC int HTCheckForInterrupt NOARGS

and just replace its body completely with

    return NO;

and recompile.  That should give you a new lynx that acts "only" as
broken as the old ones.

As for problem 2 -

We had a problem reported last February that seems to be exactly the same.
It was never resolved AFAIK.
Please see the threads started by "Clair Wilson" in
Maybe you can answer some of the questions that were never answered,
maybe you can trace the execution so that we'll finally know what
syscall fails, or you can run it under a debugger and find out what
exactly fails in function HTDoConnect.

Or try to get an answer from IBM.  Obviously some system upgrade destroyed
binary compatibility for some program(s).  Maybe it has been fixed since
that upgrade came out.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]