[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: lynx-dev Crypto Question

From: Ismael Cordeiro
Subject: Re: lynx-dev Crypto Question
Date: Sat, 2 Oct 1999 10:19:26 -0400 (EDT)

On Fri, 1 Oct 1999, Janina Sajka wrote:

> > > SSL_DIR= ~isrd/bin/lynx282
> > > SSL_LIBS= -L$(SSL_DIR)/lib -lssl -lcrypto
> > > SSL_DEFINES= -I$(SSL_DIR)/include -DUSE_SSL
> > 
> > If "isrd" is your home directory, try using SSL_DIR=~/isrd/bin/lynx282
> Yes, I've done that too. No cigar. I've tried both with a full path, and
> with ~isrd. It fails differently, but it fails.

"It fails differently, but it fails" is too vague and doesn't help us to
understand what is going on. Why don't you try one way at a time and tell us
what happens each way? For instance, begin with "/helen1/isrd/bin/lynx282" as
SSL_DIR and show us where it fails.

> > I can't see what's the problem except for a wrong path. Which version of
> > SSL are you using?
> Ah, it's 0.9. something from August 1999. The OpenSSL site had it named as
> the latest. It compiled with no problems just a few days ago.

Then it's version 0.94. I suggest you to replace in the SSL patch all

+ #include <ssl.h>


+ #include <crypto.h>


+ #include <openssl/ssl.h>


+ #include <openssl/crypto.h>

> > > PS: I've tried using a full path, /helen1/isrd/bin/lynx282 -- but
> > > that's even worse. make barely gets going before I fail on an error
> > > that it can't find /helen1/isrd/bin/lynx282/include -- though it's most
> > > assuredly there.
> > 
> > Go to that "lynx282" directory and enter "pwd". What does it say?
> pwd yields:
> /helen1/isrd/bin/lynx282
> ls yields:
> bin/      include/  lib/      ls.txt    openssl/  pwd.txt
> PS: I put the 'ls' and 'pwd' output in .txt files -- just to close this
> question! <grin>

Then the problem is somewhere else. Change the includes in the patch, use
"/helen1/isrd/bin/lynx282" as the SSL_DIR and tells us what happens.

> > I have no specific suggestion. I've never had problems I could not solve
> > when compiling SSLeay or openSSL and then compiling lynx with SSL. On
> > this system here my home directory is "/home/ismael", the directory where
> > I compile lynx is "/home/ismael/lynx", the SSL directory is
> > "/home/ismael/ssl" and everything works fine.
> It sounds like the only thing I'm doing differently is that I'm compiling
> from a different directory and asking for the executable to be placed in
> ~isrd/bin/lynx282. Otherwise, it sounds the same.
> I'm compiling from ~isrd/bin/tmp/lynx2-8-2. 

I don't think that is the problem. I never "install" lynx. Wherever I
compile lynx, I copy it manually to the /home/ismael/bin directory. I only
use "--libdir=$HOME" to tell lynx where to find lynx.cfg.

       |                                                             |
       | ISMAEL CORDEIRO            | mailto:address@hidden     |
       | Production sound mixer     |    |
       | Montréal - Québec - Canada | |

reply via email to

[Prev in Thread] Current Thread [Next in Thread]