lwip-users
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[lwip-users] Re: [lwip] RFC - Raw API for lwIP 0.5


From: Adam Dunkels
Subject: [lwip-users] Re: [lwip] RFC - Raw API for lwIP 0.5
Date: Wed, 08 Jan 2003 22:34:57 -0000

Hi Horst!

On Wednesday 28 November 2001 13.57, you wrote:
> Hi,
>
> > - err_t tcp_write(struct tcp_pcb *pcb, void *dataptr, u16_t len,
> >                   u8_t copy)
>
> If it's possible I would preferr
>
>      err_t tcp_write(struct tcp_pcb *pcb, const void *dataptr, u16_t len,
>                      u8_t copy)
>
> because this would suppress warnings sending data from ROM.

Good point, thanks. I'll change it immediately.

> No other comments - I'll try the cvs stack and do some test with the
> new raw API...
>
> But a last question:
> What is the preferred way for UDP connections? Do I need the "old"
> sequential API for UDP?

UDP provides a similar API as TCP does, but with some differences. The UDP 
interface is simpler since UDP is way simpler than TCP. The interface isn't 
documented yet, but the ideas are the same as the TCP interface and the code 
which implements the functions shouldn't be hard to follow. The functions are 
defined in the src/include/lwip/udp.h file. Note that the 0.4.2 udp.h and the 
CVS version until recently uses the old function names (udp_pcb_new() etc.).

/adam
-- 
Adam Dunkels <address@hidden>
http://www.sics.se/~adam
[This message was sent through the lwip discussion list.]




reply via email to

[Prev in Thread] Current Thread [Next in Thread]