lwip-commits
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[lwip-commits] [SCM] lwIP - A Lightweight TCPIP stack branch, master, up


From: Dirk Ziegelmeier
Subject: [lwip-commits] [SCM] lwIP - A Lightweight TCPIP stack branch, master, updated. 13fb616bb260057f481c5ed93396650b4d9dbf84
Date: Thu, 6 Oct 2016 10:56:51 +0000 (UTC)

This is an automated email from the git hooks/post-receive script. It was
generated because a ref change was pushed to the repository containing
the project "lwIP - A Lightweight TCPIP stack".

The branch, master has been updated
       via  13fb616bb260057f481c5ed93396650b4d9dbf84 (commit)
       via  0c0607381950c3169c7f3fc3eae8ed1b0ffb1ffd (commit)
       via  50e09ccd2c7310348f8ab7d3f57ae0608e72c0bc (commit)
      from  fa211096c2ae892263152a3168eada8211d95e44 (commit)

Those revisions listed above that are new to this repository have
not appeared on any other notification email; so we list those
revisions in full, below.

- Log -----------------------------------------------------------------
commit 13fb616bb260057f481c5ed93396650b4d9dbf84
Author: Dirk Ziegelmeier <address@hidden>
Date:   Thu Oct 6 12:55:57 2016 +0200

    Cleanup hton*/ntoh* function handling and platform abstraction
    Let lwip use functions/macros prefixed by lwip_ internally to avoid naming 
clashes with external #includes.
    Remove over-complicated #define handling in def.h
    Make functions easier to override in cc.h. The following is sufficient now 
(no more LWIP_PLATFORM_BYTESWAP):
    #define lwip_htons(x) <your_htons>
    #define lwip_htonl(x) <your_htonl>

commit 0c0607381950c3169c7f3fc3eae8ed1b0ffb1ffd
Author: Dirk Ziegelmeier <address@hidden>
Date:   Thu Oct 6 09:26:59 2016 +0200

    Avoid code duplication in def.c

commit 50e09ccd2c7310348f8ab7d3f57ae0608e72c0bc
Author: Dirk Ziegelmeier <address@hidden>
Date:   Thu Oct 6 09:22:16 2016 +0200

    Add note about new abstactions for itoa(), strnicmp(), stricmp() and 
strnstr() to UPGRADING document

-----------------------------------------------------------------------

Summary of changes:
 UPGRADING                        |    3 ++
 doc/rawapi.txt                   |    5 +--
 src/api/netdb.c                  |    4 +-
 src/api/sockets.c                |    8 ++--
 src/apps/lwiperf/lwiperf.c       |    6 +--
 src/apps/mdns/mdns.c             |   44 +++++++++----------
 src/apps/sntp/sntp.c             |    8 ++--
 src/apps/tftp/tftp_server.c      |   10 ++---
 src/core/def.c                   |   46 +++++---------------
 src/core/dns.c                   |   16 +++----
 src/core/inet_chksum.c           |   14 +++---
 src/core/ipv4/autoip.c           |    6 +--
 src/core/ipv4/dhcp.c             |   30 ++++++-------
 src/core/ipv4/etharp.c           |    6 +--
 src/core/ipv4/ip4.c              |   28 ++++++------
 src/core/ipv4/ip4_addr.c         |    2 +-
 src/core/ipv4/ip4_frag.c         |   22 +++++-----
 src/core/ipv6/ip6_addr.c         |    6 +--
 src/core/ipv6/ip6_frag.c         |   10 ++---
 src/core/ipv6/nd6.c              |   14 +++---
 src/core/netif.c                 |    4 +-
 src/core/tcp.c                   |   10 ++---
 src/core/tcp_in.c                |   30 ++++++-------
 src/core/tcp_out.c               |   72 +++++++++++++++----------------
 src/core/udp.c                   |   22 +++++-----
 src/include/lwip/def.h           |   42 +++---------------
 src/include/lwip/inet_chksum.h   |    8 +---
 src/include/lwip/ip4_addr.h      |    6 +--
 src/include/lwip/ip6_addr.h      |   32 +++++++-------
 src/include/lwip/priv/tcp_priv.h |    2 +-
 src/include/lwip/prot/ethernet.h |    2 +-
 src/include/lwip/prot/ip6.h      |   12 +++---
 src/include/lwip/prot/tcp.h      |   14 +++---
 src/include/netif/ppp/eui64.h    |    2 +-
 src/include/netif/ppp/mppe.h     |    2 +-
 src/netif/ethernet.c             |    8 ++--
 src/netif/lowpan6.c              |   62 +++++++++++++--------------
 src/netif/ppp/auth.c             |   10 ++---
 src/netif/ppp/ipcp.c             |   88 +++++++++++++++++++-------------------
 src/netif/ppp/ipv6cp.c           |    4 +-
 src/netif/ppp/multilink.c        |    4 +-
 src/netif/ppp/ppp.c              |    4 +-
 src/netif/ppp/pppoe.c            |   14 +++---
 src/netif/ppp/utils.c            |    2 +-
 src/netif/ppp/vj.c               |   62 +++++++++++++--------------
 45 files changed, 375 insertions(+), 431 deletions(-)


hooks/post-receive
-- 
lwIP - A Lightweight TCPIP stack



reply via email to

[Prev in Thread] Current Thread [Next in Thread]