[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Linphone-users] linphonec error loading shared lib on ARM

From: sanil d
Subject: Re: [Linphone-users] linphonec error loading shared lib on ARM
Date: Thu, 13 Sep 2007 09:57:19 +0530

as god lu mentioned, please check all the libraries are present or not.
During the compilation process, everything went well? Did you add all the install directory structure including all the files to the board. One more tip is that, please tar the installed directory on the compiled machine and take that tar to the board and untar their. It help to keep all the links intact.
Also, make sure that your paths are set properly on the board.
all the best.

On 9/13/07, god lu <address@hidden> wrote:
   You can use arm-linux-ldd to check which lib your board doesn't have, and add it.
   The usage of arm-linux-ldd is;
    arm-linux-ldd  linphonec
    Then it will display all the libs linphonec needs.
     Good luck.

2007/9/12, Cheng-Yen Lin <address@hidden>:
Hi, thanks for your reply

I try that, but still the same problem @@

On 9/12/07, sanil d < address@hidden > wrote:
in the second case, did you set the LD_LIBRARY_PATH for the libraries?
When i tried cross compilation, i copied the installed directories with all the related libs and files (usr/local/<directories>) to the board and set the LD_LIBRARY_PATH to usr/local/lib. It worked.
See my command line option for configure::
./configure --prefix=<give the prefix for install dir> --host=<cross tool like arm-linux --with-gnu-ld --disable-static --disable-glib --with-osip=$ARM_INSTALL_TREE/usr/local OSIP_CFLAGS="-I$ARM_INSTALL_TREE/usr/local/include" OSIP_LIBS="-L$ARM_INSTALL_TREE/usr/local/lib -losip2 -losipparser2" --with-readline=$ARM_INSTALL_TREE/usr/local SPEEX_CFLAGS="-I$ARM_INSTALL_TREE/usr/local/include" SPEEX_LIBS="-L$ARM_INSTALL_TREE/usr/local/lib -lspeex " PKG_CONFIG_PATH=$ARM_INSTALL_TREE/<path for pkgconfig> --disable-video
make install
make install DESTDIR= <give your path>
I compiled without video.
Hope this helps.
On 9/11/07, Cheng-Yen Lin < address@hidden > wrote:

I try to cross compile linphonec  fro arm-linux . First of all I successfully  cross compiled libosip2( 2.2.2), speex(1.2),  readline(5.1), ncurses(5.6). Then I configure linphone:

 ./configure  --with-osip=/root/nthu/arm
-2007q1/arm-none-linux-gnueabi/ --with-readline=/root/nthu/arm-2007q1/arm-none-linux-gnueabi/ --pref
ix=/root/nthu/arm-2007q1/arm-none-linux-gnueabi/ --host=arm-none-linux-gnueabi SPEEX_CFLAGS="-I/root/nthu/arm-2007q1/arm-none-linux-gnueabi/include" SPEEX_LIBS
="-L/root/nthu/arm-2007q1/arm-none-linux-gnueabi/include -lspeex" --disable-glib --disable-video --enable-gtk_ui=no

Then make, everything goes fine but while I execute "linphonec" on my ARM board, It has the following
error message:
cd: 1: can't cd to /root/nthu/linphone-1.7.0/console
eval: 1: arm-none-linux-gnueabi-gcc: not found

it seems the shared library problem, so I re-configure linphone with the following

./configure  CFLAGS=-static --with-osip=/root/nthu/arm-2007q1/arm-none-linux-gnueabi/ --with-readline=/root/nthu/arm-2007q1/arm-none-linux-gnueabi/ --pref
ix=/root/nthu/arm-2007q1/arm-none-linux-gnueabi/ --host=arm-none-linux-gnueabi SPEEX_CFLAGS="-I/root/nthu/arm-2007q1/arm-none-linux-gnueabi/include" SPEEX_LIBS
="-L/root/nthu/arm-2007q1/arm-none-linux-gnueabi/include -lspeex" --disable-glib --disable-video --enable-gtk_ui=no

I add -static to the cflags, but while execution still has the following error message:

./linphonec: error while loading shared libraries: cannot open
 shared object file: No such file or directory

I try to compile readline with the "-static" option, but still not work. I stack for a while @@

Can someone know how to solve this? any advice will be great help, thanks!!!

Linphone-users mailing list

Linphone-users mailing list


Today is most important.

Linphone-users mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]