[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Linphone-users] Re: Please don't use private IP addresses

From: Luca Olivetti
Subject: Re: [Linphone-users] Re: Please don't use private IP addresses
Date: Thu, 29 Mar 2007 12:09:37 +0200

On 3/28/07, Luca Olivetti <address@hidden> wrote:
On 3/27/07, Luca Olivetti <address@hidden> wrote:
> En/na Luca Olivetti ha escrit:
> > Hello,
> > this is the message I get when trying to register with skypho
> > ( using linphonec-1.6.0 (on arm). The registration
> > message is (sorry, I changed my mumber with xxxx):
> >
> > Via: SIP/2.0/UDP;rport;branch=z9hG4bK994602703
> > From: <sip:address@hidden>;tag=1739220843
> > To: <sip:address@hidden>
> > Call-ID: address@hidden
> > CSeq: 1 REGISTER
> > Contact: <sip:address@hidden:5060>


Well, if in exosip/jrequest.c, function
generating_request_out_of_dialog I force locip to my public ip I can
successfully register with, so either
eXosip_get_localip_for is broken or it's not the right function to
call in this context.

Mmmh, I just removed my modification and I can register now. This time
in the "Unathorized" reply there's a "received" field that linphone
uses for the subsequent, successfull, authentication. So I suppose it
was a stupid mistake on my part before, but...

But then, even if I successfully register, I cannot make a call: in
the log I see that I continually get proxy authorization requests, and
each time linphone adds a new proxy-authorization header.

..this hasn't changed. However I can receive calls.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]