lilypond-user
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Strings as variable names


From: Josiah Boothby
Subject: Re: Strings as variable names
Date: Wed, 6 Jan 2016 00:47:32 -0800

Sorry to delve into this a bit late, but an earlier point in this
ongoing thread is relevant to work currently on my desk :)

On Mon, 28 Dec 2015 19:20:28 +0100
David Kastrup <address@hidden> wrote:

> > flute_phrase01 =
> > flute_phrase02 =
> >
> > or similar.
> 
> When would you ever want to do that?

Actually, I've got two use cases for this loaded in my editor right
now. The first (an older, ongoing project) is a set of about 150 simple
etudes. I can use--and am using--Roman numerals. It feels like a little
bit of a cludge, but it works. The second is a bit more involved. 

I'm writing a set of accuracy training exercises that involve
simple permutations of chromatic trichords (e.g., changes of order, and
octave shifts). I'm currently using Roman numerals because there is no
reasonable concise, descriptive name of each permutation that does not
involve enumeration, and Arabic numbers are out of the question. So I
have a legend at the top of each include file describing what my
nomenclature means:

% Trichord Variable Names
% 012: A
% 013: B                        
% 014: C                        
% 015: D                        
% 016: E                        
% 024: F                        
% 025: G                        
% 026: H                        
% 027: I                        
% 036: J
% 037: K
% 048: L
% 
% Permutations: 
% Aa, Ab, Ac, Ad, etc.
% 
% Permutation Variations:
% AaI, AaII, AaIII, etc.
% 
% Respellings (enharmonic respelling for legibility):
% AaIi, AaIii, AaIiii, etc.

Now, yes, I'm sure that with a handful of hours of trying to learn
Scheme, I could probably find a way to do this that doesn't involve so
many lines of Lilypond code, but my free time to work on this
particular project is in half-hours here and there: learning enough
scheme to do this is impractical. So in the meantime, I basically have
to give each three-note motive a variable with a coded name that allows
sufficient differentiation and can be searched reasonably easily.
Variables with Arabic numerals would make these far more descriptive
and easier to read! Such as, for instance, trichord (0,1,6), in the
form and ordering of (0,11,5), enharmonic spelling version "c": 

\016_0e5-c

...instead of:

\EbIIiii  

...which is oblique and obnoxious to read. (And which I have to remind
myself not to read as "E-flat...er...major? Minor? Huh?")

Again, programming with scheme is almost definitely the correct--or at
least most efficient and elegant--approach. But for reasons of time
management for a freelance performer with next to zero programming
experience, the preparatory study requirements make this superior
approach non-pragmatic. 

Best,

Josiah



reply via email to

[Prev in Thread] Current Thread [Next in Thread]