[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

tetex version games

From: Laura Conrad
Subject: tetex version games
Date: Fri, 21 Oct 2005 09:27:50 -0400
User-agent: Gnus/5.110004 (No Gnus v0.4) Emacs/21.4 (gnu/linux)

I just succeeded in something that took me several hours to figure
out, so I thought I'd pass the magic words on here in case someone
else needs to do it.

This is on a debian Sid system where I would like to run lilypond 2.0.

The problem was that an update script stupidly upgraded tetex to 3.0.
I found that my lilypond 2.0 wouldn't work at all with tetex 3.0.
Googling, I saw that support for tetex 3.0 was introduced in lilypond

So I decided to roll tetex back to 2.0.

I don't back up system files, but my backup script does save output of
"dpkg -l".

Even after I managed to install the exact tetex-* packages that had
been in place on the previous backup, I was still getting the error
messages from latex that I'd gotten with tetex 3.0.  (Don't bother
trying to roll back tetex with apt-get -- the dependencies are
remarkably screwed up, and dpkg goes into a loop.)

The answer turns out to be that you do a purge of the 3.0 packages
(dpkg -P --force-all) before installing the 2.0 packages (with dpkg
using the packages in /var/cache/apt/archives).  Now lilypond 2.0
seems to be happy again.

However, I think you can for practical purposes date the demise of
lilypond 2.0 (and 2.2) as supported packages on lilypond Sid to this
week, when tetex 3.0 became the version supported by apt-get.  

Laura (mailto:address@hidden , )
(617) 661-8097  fax: (501) 641-5011
233 Broadway, Cambridge, MA 02139

reply via email to

[Prev in Thread] Current Thread [Next in Thread]