libtool-patches
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: CVS Head - patch to remove extraneous code in temp_rpath calcs.


From: Bob Friesenhahn
Subject: Re: CVS Head - patch to remove extraneous code in temp_rpath calcs.
Date: Mon, 29 Nov 2004 08:08:45 -0600 (CST)

On Mon, 29 Nov 2004, Gary V. Vaughan wrote:

Hi Bob!

Bob Friesenhahn wrote:
The following patch removes code which is no longer needed.  Ok to apply?

We can simplify more than that now:

--- config/ltmain.m4sh    28 Nov 2004 19:55:40 -0000    1.27
+++ config/ltmain.m4sh    29 Nov 2004 03:14:53 -0000
@@ -3516,7 +3516,6 @@
         if test -n "$shlibpath_var"; then
           # Make sure the rpath contains only unique directories.
           case "$temp_rpath " in
-          *" $dir "*) ;;
           *" $absdir "*) ;;
           *) temp_rpath="$temp_rpath $absdir" ;;
           esac

This hunk can become:

          if test -n "$shlibpath_var"; then
            # Make sure the rpath contains only unique directories.
            case ":$rpath:" in
              *":$absdir:"*) ;;
              *) rpath="$rpath$absdir:" ;;
            esac

The reason I didn't do this is that 'rpath' is used as a temporary variable in a number of other places. It seems to me that a variable used to carry state throughout the script should have a consistent meaning and should not be used as a temporary variable. I do agree that 'rpath' is a much better name than 'temp_rpath'.

We could change existing 'rpath' to 'temp_rpath' and change existing 'temp_rpath' to 'rpath'. :-)

Bob
======================================
Bob Friesenhahn
address@hidden
http://www.simplesystems.org/users/bfriesen




reply via email to

[Prev in Thread] Current Thread [Next in Thread]