[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: Memory error while committing...

From: Lemke, Michael SZ/HZA-IOM1
Subject: RE: Memory error while committing...
Date: Mon, 4 Jun 2007 11:55:17 +0200

Mark D. Baushke <> wrote on Sunday, June 03, 2007 8:46 AM:
> James Depaul <address@hidden> writes:
>> I've asked the Unix Admin to bump up the security limits file for us
>> as follows: 
>>         data = 524288
>>         rss = 131072
>>         stack = 131072
>> I've tried it again after re-logging and the same error persists -
>> giving up.

There is another snatch with AIX and memory.  AIX still uses a
segmented memory model. Your executable needs to be linked to use the
`large memory' model. I don't know if your cvs executable is properly 
linked.  If not you will never get more than 256MB of memory even if 
all ulimits allow it.

You can check it with

dump -o /path/to/cvs

In the output you'll find a line with maxDATA.  The value must be 
0x80000000.  If it isn't you can patch the cvs executable with

ldedit -b maxdata:0x80000000 /path/to/cvs

That simply makes up for the missed linker flag when cvs was built.

Just a thought.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]