[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: How to move a repository from linux to windows?

From: Kelly F. Hickel
Subject: RE: How to move a repository from linux to windows?
Date: Wed, 3 May 2006 13:38:38 -0500

> -----Original Message-----
> From: Jim Hyslop [mailto:address@hidden
> > I end up with the same result. When using a downloaded windows
> binary of
> > 1.12.13, if I do a cvs co it goes through all the motions, creates
> all
> > the directories and so forth, but none of the files are there.....
> What does 'cvs --version' show?

 [Kelly F. Hickel] This happens even with the 1.12.13 binary I
downloaded from (well, wherever it is now that it moved):
D:\Temp\cvstest>cvs12 --version
Concurrent Versions System (CVS) 1.12.13 (client)

> > Any ideas?  I've seen various goggle results say that the repository
> > files always have unix style line endings regardless of the host
> > platform, and I've even tried going through every file and
> converting it
> > to dos style line endings with the same results.
> Oh, don't do that. Heed what you have read - CVS expects the files to
> have LF-only line endings, and you could confuse it by changing
> things.

 [Kelly F. Hickel] Yeah, I was a little desperate...  I wrote the perl
script and let it run over dinner, so it didn't cost me that much (just
4.1BG of disk space for the extra repo copy).  Surprisingly, it made no
difference in the results whatsoever.

> Does CVS work on files that it creates? For example, in one of these
> directories that it creates, create a new file and check it in. If
> that
> works OK, then there may be a problem with the files you've copied
> over.
> If it doesn't work, then it's your CVS executable.

 [Kelly F. Hickel] Yeah, that's what I thought, but I'm using the one I
downloaded at the moment, since I don't trust the one that I built at
all.  I used it to create a repo, imported a single file into it, and
all was working properly.  I even went so far as to do "cvs -ttttttt co
xyz" against both repos and compare the trace output.  It's completely
identical (except for the repo names of course), but with the repo I
created on windows, I get files, with the repo I moved from linux, I
just get the directories.

I did find out that if I go into one of the empty directories and do a
cvs up on a file name, the file gets checked out.  Makes me suspect
something's wrong with the way globbing is working in the copied repo.

> A simple binary copy of the repository should work fine. If you're
> using
> FTP, make sure you force binary mode.
> - --
> Jim Hyslop
> Dreampossible: Better software. Simply.
>                  Consulting * Mentoring * Training in
>     C/C++ * OOD * SW Development & Practices * Version Management
> Version: GnuPG v1.4.2 (MingW32)
> Comment: Using GnuPG with Thunderbird -
> iD8DBQFEWMGQLdDyDwyJw+MRAjyeAKCIGsVIciEqVOBswiyBrj/p/A6E3gCg2cyd
> el++Hm610RYbgg4KOzJq62I=
> =QA3t


Kelly F. Hickel
Senior Software Architect
MQSoftware, Inc

reply via email to

[Prev in Thread] Current Thread [Next in Thread]