[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Strange update behavior

From: Christian Schmolzi
Subject: Re: Strange update behavior
Date: Thu, 25 Aug 2005 07:53:20 +0000 (UTC)
User-agent: Xnews/5.04.25

Mark D. Baushke wrote:

>> I have noticed a strange behavior that occured exactly two times in
>> the last few weeks. I tried to update my sandbox (Sun Solaris, CVS
>> client 1.12) from a branch to HEAD with "cvs -PAd". Strangely, one
>> file, that was added 
> I assume you mean 'cvs update -PAd' as the command?

exactly :-)

>> Several update tries with differnt options did not succeed. The only
>> way to get the file from the repository was by telling cvs
>> explicitely which file to update ("cvs update -P file.txt"). Another
>> colleague of me reported this behavoir happened with his windows
>> client (WinCvs). 
> What does a 'cvs status file.txt' tell you (before and after you do
> the update)? Does another 'cvs update -PAd' cause file.txt to
> disappear? 

I can't tell you much about the 'cvs status' output, because after the 
'cvs update file.txt' I could not reproduce the problem anymore. But if I 
remember correctly, it said 'Nothing known about file.txt', but I am not 
100% sure. I noticed, that in CVS/Entries there was no entry for that 
file, but as that file did not exist in the branch that was checked out 
before I think that was ok.

Another 'cvs update -PAd' left file.txt unchanged. 

> You don't happen to have both a file.txt directory and a file.txt,v
> file in your repository do you? (Although I would have expected you to
> have run across a 'file.txt already exists but is not a directory'
> kind of error message in that case).

No, there was only the file.txt,v in the repository

Thanks for your answer,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]