[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Help! 30 second delay on every command going thru pserver!?

From: Richard Pfeiffer
Subject: Re: Help! 30 second delay on every command going thru pserver!?
Date: Fri, 14 Nov 2003 09:21:19 -0800 (PST)

Exclusive locking of the file and the "locking" that cvs refers to are two different things.  Anyone, correct me if I'm mistaken here, but your file(s) (actually, I believe it's the directory where those files are archived) is being temporarily locked as you are checking them out or updating them. Once that dir is checked out, it releases the lock on that dir and moves on to the next dir in the project.  Thus, if someone else is trying to do a checkout at the exact same time you are currently checking said directory out, they will have to wait and cvs will 'sleep'.  This 30 second wait was upgraded in 1.11.6 to wait for 2, 4, 8 .... up to 512 microseconds before then defaulting to a 30 second wait.  You wouldn't want it to constantly keep checking or you'd have a great deal of processor time being spent just checking to see if your process can go yet.


Look at the section where you read about the 30 second lock time originally.  I believe it even prefaces it with a note not to confuse the meaning of "lock".



Andreas Rehn <address@hidden> wrote:



I have a very strange problem with cvs. We have a Pentium machine running cvs on a Redhat 7.3 on our LAN and it’s been working ok for quite a while. We connect with pserver and that seams to work fine for everybody except me, every command I run has an exact 30 s delay which I don’t need to say is very irritating. I’ve tried different cvs clients, 1.10, 1.11.5, 1.11.9, WinCVS, TortoiseCVS with the same result. I’ve also tried with my colleagues accounts from my computer with the same result. I’ve even tried telnet directly to port 2401 and writing some rubbish, and it seams to take 30 for cvs to send me the error message. I’ve even tried with a different network card in my computer with no luck. The only thing I can think of that I have differently from my colleagues is that I run Win XP and they Win 2000.


I browsed thru all the FAQa and searched the mail-archives and not found anything that helps me. Thru the mail-archive I found that there’s a default 30 s delay on file locks in cvs but that shouldn’t bother us since we don’t use exclusive checkout, should it?


As you can see below running a cvs log –t command along with a tcpdump on port 2401 gives a delay on 30 s after some initial handshake and it’s the same for all commands on all files.


I have no more ideas on how to overcome this problem so I sincerely hope that someone out there can help me figure out this thing.


Thanks in advance




CVS Command:

D:\Work\Development\mecp\mwaf>cvs -t log build.xml

-> main loop with CVSROOT=:pserver:address@hidden:/home/cvs/repository

 -> Connecting to brink(


RCS file: /home/cvs/repository/mwaf/build.xml,v

Working file: build.xml

head: 1.7


locks: strict

access list:

symbolic names:


        avendor: 1.1.1

keyword substitution: kv

total revisions: 8;     selected revisions: 8



revision 1.7

date: 2003/11/11 09:21:51;  author: anre42;  state: Exp;  lines: +5 -5

minor changes to jar_public



< some stuff removed here>




date: 2003/10/03 13:07:14;  author: anre42;  state: Exp;  lines: +0 -0

no message


-> Lock_Cleanup()


TCP Dump on port 2401:

address@hidden anre42]# /root/src/tcpdump-3.7.2/tcpdump port 2401

tcpdump: listening on eth0

17:09:17.944772 > brink.produktion.cvspserver: S 2956441927:2956441927(0) win 16384 <mss 1260,nop,nop,sackOK> (DF)

17:09:17.944796 brink.produktion.cvspserver > S 2083175851:2083175851(0) ack 2956441928 win 5840 <mss 1460,nop,nop,sackOK> (DF)

17:09:17.945278 > brink.produktion.cvspserver: . ack 1 win 17640 (DF)

17:09:17.947502 > brink.produktion.cvspserver: P 1:75(74) ack 1 win 17640 (DF)

17:09:17.947537 brink.produktion.cvspserver > . ack 75 win 5840 (DF)

17:09:47.964708 brink.produktion.cvspserver > P 1:12(11) ack 75 win 5840 (DF)

17:09:47.966455 > brink.produktion.cvspserver: P 75:458(383) ack 12 win 17629 (DF)

17:09:47.966651 brink.produktion.cvspserver > . ack 458 win 6432 (DF)

17:09:47.966943 brink.produktion.cvspserver > P 12:608(596) ack 458 win 6432 (DF)

17:09:47.969040 > brink.produktion.cvspserver: P 458:471(13) ack 608 win 17033 (DF)

17:09:48.000016 brink.produktion.cvspserver > . ack 471 win 6432 (DF)

17:09:48.000763 > brink.produktion.cvspserver: P 471:610(139) ack 608 win 17033 (DF)

17:09:48.000899 brink.produktion.cvspserver > . ack 610 win 7504 (DF)

17:09:48.004175 brink.produktion.cvspserver > . 608:1868(1260) ack 610 win 7504 (DF)

17:09:48.004193 brink.produktion.cvspserver > P 1868:2138(270) ack 610 win 7504 (DF)

17:09:48.007040 > brink.produktion.cvspserver: . ack 2138 win 17640 (DF)

17:09:48.007184 brink.produktion.cvspserver > P 2138:2141(3) ack 610 win 7504 (DF)

17:09:48.093641 > brink.produktion.cvspserver: F 610:610(0) ack 2141 win 17637 (DF)

17:09:48.094572 brink.produktion.cvspserver > F 2141:2141(0) ack 611 win 7504 (DF)

17:09:48.095245 > brink.produktion.cvspserver: . ack 2142 win 17637 (DF)

Info-cvs mailing list

Do you Yahoo!?
Protect your identity with Yahoo! Mail AddressGuard
reply via email to

[Prev in Thread] Current Thread [Next in Thread]