[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

CVS Layout problem

From: Charles Gagnon
Subject: CVS Layout problem
Date: Thu, 13 Nov 2003 14:35:07 -0500
User-agent: Mutt/1.4i

I trying to setup a new CVS repository. I would like my various
modules to share the same src/ tree so I will not have a seperate
subdirectory for each project. Here's my first approach:

 0. cvs -d $CVSROOT init
 1. cd $home/project1
 2. cvs import -m "Imported Source" . project1 start

This works fine. I can look in my repository and I see:

  ls -l $CVSROOT

And $CVSROOT/src contains my java sources:


I than modified the CVSROOT/modules file to create new module:

  % cat modules
  project1                ./ ./project1 ./project1.xml \
                          &src/com/ox/db \
                          &src/com/ox/esi \
                          &src/com/ox/rv \
                          &src/com/ox/security \
                          &src/com/ox/trade \
                          &src/com/ox/tools \
  src/com                 src/com
  src/com/ox              src/com/ox
  src/com/ox/db           src/com/ox/db
  src/com/ox/esi          src/com/ox/esi
  src/com/ox/rv           src/com/ox/rv
  src/com/ox/security     src/com/ox/security
  src/com/ox/tools        src/com/ox/tools
  src/com/ox/trade        src/com/ox/trade
  src/com/ox/utils        src/com/ox/utils

I can now checkout my project just fine:

  % cvs checkout project1

Of course, now everything shows up in $home/project1/ but I can
build the project and run it just fine. But I *CANNOT* check it back
in and I have not idea why. I retried from scratch a couple of times
and got the same resutls:

  % cvs checkin project1

  cvs commit: Examining project1
  cvs commit: Up-to-date check failed for `project1/.'
  cvs commit: Examining project1/src
  cvs commit: Examining project1/src/com
  cvs commit: Examining project1/src/com/ox
  cvs commit: Examining project1/src/com/ox/db
  cvs commit: Examining project1/src/com/ox/esi
  cvs commit: Examining project1/src/com/ox/esi/command
  cvs commit: Examining project1/src/com/ox/esi/event
  cvs commit: Examining project1/src/com/ox/esi/record
  cvs commit: Examining project1/src/com/ox/rv
  cvs commit: Examining project1/src/com/ox/security
  cvs commit: Examining project1/src/com/ox/security/rv
  cvs commit: Examining project1/src/com/ox/tools
  cvs commit: Examining project1/src/com/ox/trade
  cvs commit: Examining project1/src/com/ox/utils
  cvs [commit aborted]: correct above errors first!

>From the I tried "cd project1" and than "cvs commit ." or "cvs
commit" and I get the same results. I also tried various
combinations with "cvs update" but I alway get:

  cvs update: conflict: project1/. is modified but no longer in the repository

I'm not sure I'm following what the problem is. 

Charles Gagnon                   | My views are my views and they             | do not represent those of anybody
charlesg at        | but me.

   To err is Human, to forgive is against Departmental Policy!

reply via email to

[Prev in Thread] Current Thread [Next in Thread]