[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

CVSROOT/passwd problems.

From: Gagneet Singh
Subject: CVSROOT/passwd problems.
Date: Thu, 26 Dec 2002 17:09:32 +0530


    I have been using the SystemAuth=yes method to authenticate users for
CVS Server. (available in the CVSROOT/config file). The System I am using is
Red Hat 8 with cvs-1.11.2. The repository is in /cvs directory. The
permissions for this are ug+rwx. It belongs to root user and cvs group.

    Currently the requirements changed and I was required to setup a
scenario to use the CVSROOT/passwd file for the authentication procedure.
The steps I carried out were:
    a) Created a group 'cvs'.
    b) Assigned 5 users to it. These were already existing users on the CVS
Server machine.
    c) Copied the passwords from the System passwords file to the CVSROOT
    d) Changed permission for this as ugo+r (read only for user, group and
    e) The structure of the file is thus,


(Earlier I had also tried with giving the user name at the end., i.e.,
gagneet:hfhsdgst/gjkgj/..*&  )

On the client side I am using WinCVS 13b10. When I try to now login the
following error message is given.

cvs -d :pserver:address@hidden:/cvs login
Logging in to :pserver:address@hidden:2401/cvs
Fatal error, aborting.
cvs [login aborted]: gagneet
: no such user
***** CVS exited normally with code 1 *****

without the system username it gives:
cvs -d :pserver:address@hidden:/cvs login
Logging in to :pserver:address@hidden:2401/cvs
Fatal error, aborting.
cvs [login aborted]:
: no such user
***** CVS exited normally with code 1 *****

Also, when I give a wrong password, the following message comes up.

cvs -d :pserver:address@hidden:/cvs login
Logging in to :pserver:address@hidden:2401/cvs

cvs [login aborted]: authorization failed: server cvsserver rejected access
to /cvs for user gagneet

***** CVS exited normally with code 1 *****

This should mean that the settings on the CVS Server are fine but they are
not working with the CVSROOT/passwd file.

My cvspserver file in the /etc/xinetd.d/ directory contains the following
# default: on
# service cvspserver
service cvspserver
 disable = no
 id  = cvspserver
 env  = HOME=/home/gagneet
 socket_type = stream
 protocol = tcp
 port  = 2401
 wait  = no
 user  = root
 passenv  = PATH
 server  = /usr/bin/cvs
 server_args = -f --allow-root=/cvs pserver

Please Help. I do not know now what else is to be done.. I have tried all
from my side..

Thank you


reply via email to

[Prev in Thread] Current Thread [Next in Thread]